aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/sysbench/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-02-02 06:55:53 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-02-02 06:55:53 +0000
commit741367f1da7b3d1c3920540e590d24a101605049 (patch)
tree2ec6f4f8044ecd2f3b2ca1db0666bbbb4eea7ddf /benchmarks/sysbench/Makefile
parenta79afefc7e4fade4c60fc2740c132381af52f437 (diff)
downloadports-741367f1da7b3d1c3920540e590d24a101605049.tar.gz
ports-741367f1da7b3d1c3920540e590d24a101605049.zip
Notes
Diffstat (limited to 'benchmarks/sysbench/Makefile')
-rw-r--r--benchmarks/sysbench/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index 1c7475e198ff..f0f74912c5ca 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -11,16 +11,23 @@ CATEGORIES= benchmarks databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= gslin@gslin.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A modular, cross-platform and multi-threaded benchmark tool
USE_AUTOTOOLS= libtool:15
-OPTIONS= MYSQL "Enable MySQL support" on \
+OPTIONS= LARGEFILE "Enable Largefile support" on \
+ MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_LARGEFILE)
+CONFIGURE_ARGS+= --disable-largefile
+.else
+CONFIGURE_ARGS+= --enable-largefile
+.endif
+
.if defined(WITHOUT_MYSQL)
CONFIGURE_ARGS+= --with-mysql=no
.else