aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/webbench/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-23 23:37:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-23 23:37:38 +0000
commit8bcaa3e72367290b2af16803713c2cf90d114c00 (patch)
treeb54defedf112f3ae1a926c19a51cc50d66458852 /benchmarks/webbench/Makefile
parentd82c11ef5372480178a37c1eda4240e60868cc36 (diff)
downloadports-8bcaa3e72367290b2af16803713c2cf90d114c00.tar.gz
ports-8bcaa3e72367290b2af16803713c2cf90d114c00.zip
Notes
Diffstat (limited to 'benchmarks/webbench/Makefile')
-rw-r--r--benchmarks/webbench/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index d0b9245256e7..077e9baf64f5 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -15,6 +15,24 @@ MAINTAINER= hsn@netmag.cz
COMMENT= Simple forking web benchmark
USE_GETOPT_LONG=yes
+
+.if !defined(NO_INSTALL_MANPAGES)
MAN1= webbench.1
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= copyright changelog
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/webbench ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/webbench.1 ${MAN1PREFIX}/man/man1
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/debian/copyright ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/debian/changelog ${DOCSDIR}
+.endif
.include <bsd.port.mk>