aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-07-10 11:58:36 +0000
committerSteve Wills <swills@FreeBSD.org>2018-07-10 11:58:36 +0000
commit18343f5a702b3b4683291fe11ea431751c0589ee (patch)
treec44ab98f23e5d0033e3e653b411b29c14393ba85 /benchmarks
parentf473d4ccfc58846acf9c6b919429081b1d1da960 (diff)
downloadports-18343f5a702b3b4683291fe11ea431751c0589ee.tar.gz
ports-18343f5a702b3b4683291fe11ea431751c0589ee.zip
benchmarks/vegeta: making better use of Go framework
PR: 229668 Submitted by: Vinícius Zavam <egypcio@googlemail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=474356
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/vegeta/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/benchmarks/vegeta/Makefile b/benchmarks/vegeta/Makefile
index efd519038526..2310a90f3526 100644
--- a/benchmarks/vegeta/Makefile
+++ b/benchmarks/vegeta/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vegeta
DISTVERSIONPREFIX= v
DISTVERSION= 8.0.0
+PORTREVISION= 1
CATEGORIES= benchmarks www
MAINTAINER= egypcio@googlemail.com
@@ -11,13 +12,12 @@ COMMENT= HTTP load testing tool and library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go:lang/go
-
PLIST_FILES= bin/${PORTNAME}
+USES= go
USE_GITHUB= yes
-GH_ACCOUNT= tsenart
+GH_ACCOUNT= tsenart
GH_TUPLE= streadway:quantile:b0c5887:quantile/github.com/streadway/quantile \
golang:net:ed29d75:net/golang.org/x/net \
golang:text:v0.3.0:text/golang.org/x/text \
@@ -28,8 +28,8 @@ do-build:
@${RLN} ${WRKSRC} ${WRKSRC}/github.com/${GH_ACCOUNT}/${PORTNAME}
@${RLN} ${WRKSRC} ${WRKSRC}/src
@cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
- go build -ldflags "-X main.Version=${DISTVERSION}" -o bin/${PORTNAME}
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} CGO_ENABLED=0 GOPATH=${WRKSRC} \
+ ${GO_CMD} build -ldflags "-X main.Version=${DISTVERSION}" -o bin/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}/${LOCALBASE}/bin