aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-01-09 19:10:24 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-01-09 19:10:24 +0000
commit5c148c78ecc25e961571bba09ed2f3838fbad421 (patch)
tree649e7dd248727859ace57088fcefe01cfbe6bd90 /benchmarks
parent5acd2ba04317f34362afb6e3f404f79e599e81ff (diff)
downloadports-5c148c78ecc25e961571bba09ed2f3838fbad421.tar.gz
ports-5c148c78ecc25e961571bba09ed2f3838fbad421.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/netio/Makefile29
-rw-r--r--benchmarks/netio/distinfo2
-rw-r--r--benchmarks/netio/pkg-descr10
4 files changed, 42 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 99914326689f..d6451db6d097 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -17,6 +17,7 @@
SUBDIR += iozone21
SUBDIR += lmbench
SUBDIR += nbench
+ SUBDIR += netio
SUBDIR += netperf
SUBDIR += netpipe
SUBDIR += nttcp
diff --git a/benchmarks/netio/Makefile b/benchmarks/netio/Makefile
new file mode 100644
index 000000000000..b227c36a86c1
--- /dev/null
+++ b/benchmarks/netio/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: netio
+# Date created: 2005-01-09
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= netio
+PORTVERSION= 1.14
+CATEGORIES= benchmarks net
+MASTER_SITES= http://www.netfuse.de/techarea/netio/
+DISTNAME= netio114
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Network benchmark
+
+WRKSRC= ${WRKDIR}
+USE_ZIP= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+ALL_TARGET= unix
+PLIST_FILES= bin/netio
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lsocket,," ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/netio ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/benchmarks/netio/distinfo b/benchmarks/netio/distinfo
new file mode 100644
index 000000000000..9bed059dde2f
--- /dev/null
+++ b/benchmarks/netio/distinfo
@@ -0,0 +1,2 @@
+MD5 (netio114.zip) = 7c41f385f1c216319bfaf93639cb4a20
+SIZE (netio114.zip) = 210744
diff --git a/benchmarks/netio/pkg-descr b/benchmarks/netio/pkg-descr
new file mode 100644
index 000000000000..ed39469020a9
--- /dev/null
+++ b/benchmarks/netio/pkg-descr
@@ -0,0 +1,10 @@
+This is a network benchmark for DOS, OS/2 2.x, Windows NT/2000 and Unix.
+It measures the net throughput of a network via NetBIOS and/or TCP/IP
+protocols (Unix and DOS only support TCP/IP) using various different
+packet sizes.
+
+One instance has to run on one machine as a server process, another
+instance is used on another machine to perform the benchmark. When
+executed without arguments, the program will explain its usage.
+
+WWW: http://www.netfuse.de/techarea/netio/netio1.htm