aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 13:18:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 13:18:21 +0000
commitbf82f7adb78bef13e8050caa7d4b6ffa98c72543 (patch)
treefb65e9fdad39ec89dc7d665b97072497abd6d72c /benchmarks
parent0b61e80354910507aea86b5e1fddb914894de47a (diff)
downloadports-bf82f7adb78bef13e8050caa7d4b6ffa98c72543.tar.gz
ports-bf82f7adb78bef13e8050caa7d4b6ffa98c72543.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/mdtest/Makefile11
-rw-r--r--benchmarks/postal/Makefile9
-rw-r--r--benchmarks/sysbench/Makefile26
3 files changed, 24 insertions, 22 deletions
diff --git a/benchmarks/mdtest/Makefile b/benchmarks/mdtest/Makefile
index e557fead1426..b82e6e566b8f 100644
--- a/benchmarks/mdtest/Makefile
+++ b/benchmarks/mdtest/Makefile
@@ -16,7 +16,8 @@ COMMENT= A filesystem metadata benchmark utility
LICENSE= GPLv2
-OPTIONS= OPENMPI "Use openmpi instead of mpich2" off
+OPTIONS_DEFINE= OPENMPI EXAMPLES
+OPENMPI_DESC= Use openmpi instead of mpich2
MAN1= ${PORTNAME}.1
PORTEXAMPLES= *
@@ -24,9 +25,9 @@ PLIST_FILES= bin/${PORTNAME}
CFLAGS+= -DDarwin
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENMPI)
+.if ${PORT_OPTIONS:MOPENMPI}
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
@@ -42,9 +43,9 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/scripts && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
index 63269bc056f3..0fa7d496a8ae 100644
--- a/benchmarks/postal/Makefile
+++ b/benchmarks/postal/Makefile
@@ -17,7 +17,8 @@ COMMENT= Benchmark SMTP/POP servers
LICENSE= GPLv3
-OPTIONS= SSL "Build with OpenSSL support" on
+OPTIONS_DEFINE= SSL
+OPTIONS_DEFAULT= SSL
USE_OPENSSL= yes
GNU_CONFIGURE= yes
@@ -29,15 +30,15 @@ PLIST_FILES= sbin/bhm sbin/postal bin/postal-list sbin/rabid
MAN1= postal-list.1
MAN8= bhm.8 postal.8 rabid.8
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
CONFIGURE_ARGS= --disable-gnutls
-.if !defined(WITH_SSL)
+.if empty(PORT_OPTIONS:MSSL)
CONFIGURE_ARGS+= --disable-openssl
.endif
CFLAGS+= ${PTHREAD_CFLAGS} -Wno-long-long
LDFLAGS+= ${PTHREAD_LIBS}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index c7be93c5ecc2..625ff29cb412 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -19,26 +19,26 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_AUTOTOOLS= libtool
-OPTIONS= LARGEFILE "Enable Largefile support" on \
- MYSQL "Enable MySQL support" on \
- POSTGRESQL "Enable PostgreSQL support" off
+OPTIONS_DEFINE= LARGEFILE MYSQL PGSQL DOCS
+OTPIONS_DEFAULT= LARGEFILE MYSQL
+LARGEFILE_DESC= Enable Largefile support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_LARGEFILE)
-CONFIGURE_ARGS+= --disable-largefile
-.else
+.if ${PORT_OPTIONS:MLARGEFILE}
CONFIGURE_ARGS+= --enable-largefile
+.else
+CONFIGURE_ARGS+= --disable-largefile
.endif
-.if defined(WITHOUT_MYSQL)
-CONFIGURE_ARGS+= --with-mysql=no
-.else
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
+.else
+CONFIGURE_ARGS+= --with-mysql=no
.endif
-.if defined(WITH_POSTGRESQL)
+.if ${PORT_OPTIONS:MPOSTGRESQL}
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
.else
@@ -49,10 +49,10 @@ post-configure:
@${REINPLACE_CMD} -e 's/^program_transform_name/#/' \
${WRKSRC}/Makefile ${WRKSRC}/sysbench/Makefile
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${RM} ${DOCSDIR}/manual.html
${RMDIR} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>