aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorLawrence Stewart <lstewart@FreeBSD.org>2019-02-25 19:32:23 +0000
committerLawrence Stewart <lstewart@FreeBSD.org>2019-02-25 19:32:23 +0000
commit1df455cdcf6574b1ba93eb5321daaa55fb87f769 (patch)
tree7d10f0c846eb60b097c7a2846a9ef71cb36484ce /benchmarks
parenta3db9ba73341366f442379ef3f940d8614fad6d8 (diff)
downloadports-1df455cdcf6574b1ba93eb5321daaa55fb87f769.tar.gz
ports-1df455cdcf6574b1ba93eb5321daaa55fb87f769.zip
Assume maintainership of benchmarks/spp and update to v0.4 which addresses:
- Added pointer to http://caia.swin.edu.au/reports/130730A/CAIA-TR-130730A.pdf - Fixed threading bug that causes segfault with newer pthread lib on Linux - Directory bin is now created during make (if it doesn't exists) - Added support for DLT_PPP frames in pcap files - Create fake "ip_len" if missing (observed in some TSO'ed frames) - Noted that IP.ID is no longer useful for disambiguating packets (RFC 6864) - Added "-# 8192" to hash across first 12 bytes of TCP payload - Added "-# 16384" to hash across all TCP Option bytes - Added -O option to print 'fake' (uncorrected) OWD in each direction - Various documentation tweaks (README and man page source) - Change default hash function for packet id generation to crc64 and added - Added -H option to select hash function (crc32 and crc64) - Added autotuning of delta_t_max based on actual observed clock offset (disabled with -T option) Reviewed by: tobik@ Approved by: tobik@ Differential Revision: https://reviews.freebsd.org/D18336
Notes
Notes: svn path=/head/; revision=493891
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/spp/Makefile12
-rw-r--r--benchmarks/spp/distinfo5
-rw-r--r--benchmarks/spp/pkg-descr2
3 files changed, 13 insertions, 6 deletions
diff --git a/benchmarks/spp/Makefile b/benchmarks/spp/Makefile
index aeb5362c1bad..f6b5e976bfb7 100644
--- a/benchmarks/spp/Makefile
+++ b/benchmarks/spp/Makefile
@@ -2,16 +2,22 @@
# $FreeBSD$
PORTNAME= spp
-PORTVERSION= 0.3.6
+PORTVERSION= 0.4
CATEGORIES= benchmarks
-MASTER_SITES= http://caia.swin.edu.au/tools/spp/downloads/
+MASTER_SITES= https://bitbucket.org/caia-swin/spp/get/
+DISTNAME= v${PORTVERSION}
+DIST_SUBDIR= caia-swin-${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lstewart@FreeBSD.org
COMMENT= Calculates round trip time from pcap files or live capture
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING.txt
+USES= tar:bzip2
+BB_TAGNAME= 8b9f676fed0e
+WRKSRC= ${WRKDIR}/caia-swin-${PORTNAME}-${BB_TAGNAME}
+
PLIST_FILES= bin/spp man/man1/spp.1.gz
.include <bsd.port.mk>
diff --git a/benchmarks/spp/distinfo b/benchmarks/spp/distinfo
index d539018abd18..1a1e295cdcf7 100644
--- a/benchmarks/spp/distinfo
+++ b/benchmarks/spp/distinfo
@@ -1,2 +1,3 @@
-SHA256 (spp-0.3.6.tar.gz) = 659a04e5a6f65a3bc29d9cfa518dbb4db5a25d509b1067b32bc10c4cd055ab14
-SIZE (spp-0.3.6.tar.gz) = 42782
+TIMESTAMP = 1543220631
+SHA256 (caia-swin-spp/v0.4.tar.bz2) = f3f2d1cf3cd0c3d9e7e3da3ceb3bf4b2e7419436665f6274697535bcb561610e
+SIZE (caia-swin-spp/v0.4.tar.bz2) = 47572
diff --git a/benchmarks/spp/pkg-descr b/benchmarks/spp/pkg-descr
index a33af8a78347..d998d0f9bb32 100644
--- a/benchmarks/spp/pkg-descr
+++ b/benchmarks/spp/pkg-descr
@@ -5,4 +5,4 @@ point. SPP accurately estimates the RTT experienced by any application's
traffic without needing modifications to the application itself
or the routers along the path.
-WWW: http://caia.swin.edu.au/tools/spp/
+WWW: https://bitbucket.org/caia-swin/spp