aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2018-11-06 06:02:27 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2018-11-06 06:02:27 +0000
commit2396966d36e3daf3957005e3981122b5936a4dc1 (patch)
tree6c3d281901f4928f5c613ec8b0b246a98f542636 /benchmarks
parentc1c8ca2a288fd02d79c9b467169955a498da2cdc (diff)
downloadports-2396966d36e3daf3957005e3981122b5936a4dc1.tar.gz
ports-2396966d36e3daf3957005e3981122b5936a4dc1.zip
benchmarks/sipp: Fix OpenSSL 1.1.x build
PR: 232088 Submitted by: Nathan <ndowens@yahoo.com>
Notes
Notes: svn path=/head/; revision=484277
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile4
-rw-r--r--benchmarks/sipp/files/patch-configure.ac29
2 files changed, 30 insertions, 3 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index cfb1ae076b82..536d2043b736 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sipp
PORTVERSION= 3.5.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= benchmarks net
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${PORTVERSION}/
@@ -15,8 +15,6 @@ LICENSE= GPLv2
BROKEN_mips= fails to compile: stat.hpp:307: error: ISO C++ does not support long long
BROKEN_mips64= fails to compile: stat.hpp:307: error: ISO C++ does not support long long
BROKEN_powerpc64= fails to compile: stat.hpp:307: error: ISO C++ does not support long long
-BROKEN_SSL= openssl-devel
-BROKEN_SSL_REASON_openssl-devel= configure: error: ssl library missing
BUILD_DEPENDS= help2man:misc/help2man
diff --git a/benchmarks/sipp/files/patch-configure.ac b/benchmarks/sipp/files/patch-configure.ac
new file mode 100644
index 000000000000..2da678a00d12
--- /dev/null
+++ b/benchmarks/sipp/files/patch-configure.ac
@@ -0,0 +1,29 @@
+--- configure.ac.orig 2018-10-08 21:17:06 UTC
++++ configure.ac
+@@ -137,14 +137,15 @@ AC_SEARCH_LIBS([shutdown], [socket])
+
+ # Conditional build with OpenSSL
+ if test "$openssl" = 'yes'; then
+- AC_CHECK_HEADERS([openssl/md5.h],,[AC_MSG_ERROR([<openssl/md5.h> header missing])])
++# Conditional build with OpenSSL
++if test "$openssl" = 'yes'; then
+ AC_CHECK_HEADERS([openssl/bio.h],,[AC_MSG_ERROR([<openssl/bio.h> header missing])])
+ AC_CHECK_HEADERS([openssl/err.h],,[AC_MSG_ERROR([<openssl/err.h> header missing])])
+ AC_CHECK_HEADERS([openssl/rand.h],,[AC_MSG_ERROR([<openssl/rand.h> header missing])])
+ AC_CHECK_HEADERS([openssl/ssl.h],,[AC_MSG_ERROR([<openssl/ssl.h> header missing])])
+ AC_CHECK_HEADERS([openssl/x509v3.h],,[AC_MSG_ERROR([<openssl/x509v3.h> header missing])])
+- AC_CHECK_LIB([ssl], [SSL_library_init],,[AC_MSG_ERROR([ssl library missing])])
+- AC_CHECK_LIB([crypto], [CRYPTO_num_locks],,[AC_MSG_ERROR([crypto library missing])])
++ AC_CHECK_LIB([ssl], [SSL_CTX_new],,[AC_MSG_ERROR([ssl library missing])])
++ AC_CHECK_LIB([crypto], [CRYPTO_free],,[AC_MSG_ERROR([crypto library missing])])
+ fi
+ # For Makefile.am
+ AM_CONDITIONAL(HAVE_OPENSSL, test "$openssl" = "yes")
+@@ -156,6 +157,7 @@ if test "$sctp" = 'yes'; then
+ AC_SEARCH_LIBS([sctp_freepaddrs],[sctp sctpsp],,[AC_MSG_ERROR([SCTP library missing])])
+ AC_SEARCH_LIBS([sctp_bindx],[sctp sctpsp],,[AC_MSG_ERROR([SCTP library missing])])
+ AC_SEARCH_LIBS([sctp_recvmsg],[sctp sctpsp],,[AC_MSG_ERROR([SCTP library missing])])
++fi
+ fi
+ # For Makefile.am
+ AM_CONDITIONAL(HAVE_SCTP, test "$sctp" = "yes")