aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /benchmarks
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/clpeak/Makefile2
-rw-r--r--benchmarks/libcelero/Makefile2
-rw-r--r--benchmarks/nosqlbench/Makefile2
-rw-r--r--benchmarks/smhasher/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/benchmarks/clpeak/Makefile b/benchmarks/clpeak/Makefile
index 983c4dba5a02..f90aacdb7215 100644
--- a/benchmarks/clpeak/Makefile
+++ b/benchmarks/clpeak/Makefile
@@ -23,7 +23,7 @@ GH_TAGNAME= 75c8746
USE_LDCONFIG= yes
USE_GL= gl
-USES= cmake
+USES= cmake:insource
CXXFLAGS+= -std=c++11
diff --git a/benchmarks/libcelero/Makefile b/benchmarks/libcelero/Makefile
index 5cfc9195fc02..406d65422395 100644
--- a/benchmarks/libcelero/Makefile
+++ b/benchmarks/libcelero/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= ${LOCALBASE}/include/sys/sysinfo.h:devel/libsysinfo
-USES= cmake:outsource compiler:c++11-lang localbase:ldflags
+USES= cmake compiler:c++11-lang localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= DigitalInBlue
GH_PROJECT= Celero
diff --git a/benchmarks/nosqlbench/Makefile b/benchmarks/nosqlbench/Makefile
index ff6b8896c5e7..355bb3122d94 100644
--- a/benchmarks/nosqlbench/Makefile
+++ b/benchmarks/nosqlbench/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libleveldb.so:databases/leveldb
DATE= 20151214
-USES= cmake tar:bzip2
+USES= cmake:insource tar:bzip2
CONFLICTS= tarantool-c
diff --git a/benchmarks/smhasher/Makefile b/benchmarks/smhasher/Makefile
index e71ba91ea34c..b72f6b4b7c15 100644
--- a/benchmarks/smhasher/Makefile
+++ b/benchmarks/smhasher/Makefile
@@ -17,7 +17,7 @@ BROKEN_powerpc64= fails to compile: City.cpp: byteswap.h: No such file or direct
USE_GITHUB= yes
GH_ACCOUNT= gvnn3
-USES= cmake
+USES= cmake:insource
PLIST_FILES= bin/SMHasher