aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-03-01 17:37:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-03-01 17:37:51 +0000
commit76d701a26593f3a5c78cbc6ce28c091b4bd052a4 (patch)
tree505813422ee82144583c842f5eeb2e4df640f53f /benchmarks
parentacfcdc7aeebbc9c15b80b37ad494aa125b126c28 (diff)
downloadports-76d701a26593f3a5c78cbc6ce28c091b4bd052a4.tar.gz
ports-76d701a26593f3a5c78cbc6ce28c091b4bd052a4.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/apib/Makefile36
-rw-r--r--benchmarks/apib/distinfo3
-rw-r--r--benchmarks/apib/pkg-descr16
4 files changed, 56 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index a19cf22f972e..d895dc2846bd 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -3,6 +3,7 @@
COMMENT = Benchmarking tools
+ SUBDIR += apib
SUBDIR += autobench
SUBDIR += blogbench
SUBDIR += bombardier
diff --git a/benchmarks/apib/Makefile b/benchmarks/apib/Makefile
new file mode 100644
index 000000000000..ed73425df41e
--- /dev/null
+++ b/benchmarks/apib/Makefile
@@ -0,0 +1,36 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= apib
+PORTVERSION= 1.0
+CATEGORIES= benchmarks www
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Simple, fast HTTP performance-testing tool
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libapr-1.so:devel/apr1
+
+USE_GITHUB= yes
+GH_ACCOUNT= apigee
+GH_TAGNAME= 7e8dea9
+
+USES= localbase ssl
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= APR_LOC="${LOCALBASE}/include/apr-1"
+
+PLIST_FILES= bin/apib bin/apibmon
+PORTEXAMPLES= env.sh pivot run.sh rungroup.sh tojson
+
+OPTIONS_DEFINE= EXAMPLES
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/apib ${WRKSRC}/apibmon \
+ ${STAGEDIR}${PREFIX}/bin
+
+do-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samplescripts/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/benchmarks/apib/distinfo b/benchmarks/apib/distinfo
new file mode 100644
index 000000000000..2bce046108c2
--- /dev/null
+++ b/benchmarks/apib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503959917
+SHA256 (apigee-apib-1.0-7e8dea9_GH0.tar.gz) = d54d3abef0123071d349aff47b6bf7477ad45056c876a704e6693c894da3611e
+SIZE (apigee-apib-1.0-7e8dea9_GH0.tar.gz) = 77363
diff --git a/benchmarks/apib/pkg-descr b/benchmarks/apib/pkg-descr
new file mode 100644
index 000000000000..d49929dfc7a9
--- /dev/null
+++ b/benchmarks/apib/pkg-descr
@@ -0,0 +1,16 @@
+apib is a tool that makes it easy to test API servers. It is supported
+on Unix systems that include the Apache Portable Runtime and OpenSSL.
+
+apib has most of the features of Apache Bench (ab), but is also intended
+to be a more modern replacement. In particular, it supports:
+
+ - Proper HTTP 1.1 support including keep-alives and chunked encoding
+ - Ability to spawn multiple I/O threads to take advantage of multiple
+ CPU cores
+ - Non-blocking I/O for high concurrency
+ - Support for POST and PUT of large objects
+ - Support for OAuth 1.0 signatures
+ - Ability to output results to a file so they may be automated
+ - Remote CPU monitoring
+
+WWW: https://github.com/apigee/apib