aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 08:08:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-30 08:08:28 +0000
commit1e5d116a0ec15357ee1ce8d71e9a119d7d42f9cf (patch)
treea906bcc26cb56b0b42ce22a6209e1683cb99c3df /benchmarks
parent6f7705210481b34845b9e77f34dac47a6a164afc (diff)
downloadports-1e5d116a0ec15357ee1ce8d71e9a119d7d42f9cf.tar.gz
ports-1e5d116a0ec15357ee1ce8d71e9a119d7d42f9cf.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/Makefile37
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/distinfo3
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/pkg-descr18
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/pkg-plist3
5 files changed, 62 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 1eee36357ea0..375fb197a534 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -27,6 +27,7 @@
SUBDIR += netpipe
SUBDIR += nqueens
SUBDIR += nttcp
+ SUBDIR += p5-Benchmark-Stopwatch
SUBDIR += pathchirp
SUBDIR += pathload
SUBDIR += pathrate
diff --git a/benchmarks/p5-Benchmark-Stopwatch/Makefile b/benchmarks/p5-Benchmark-Stopwatch/Makefile
new file mode 100644
index 000000000000..91b5aea817ab
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Stopwatch/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Benchmark-Stopwatch
+# Date created: 2006-08-24
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Benchmark-Stopwatch
+PORTVERSION= 0.03
+CATEGORIES= benchmarks perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Benchmark
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple timing of stages of your code
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
+
+PERL_MODBUILD= yes
+
+MAN3= Benchmark::Stopwatch.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/benchmarks/p5-Benchmark-Stopwatch/distinfo b/benchmarks/p5-Benchmark-Stopwatch/distinfo
new file mode 100644
index 000000000000..c23180744c41
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Stopwatch/distinfo
@@ -0,0 +1,3 @@
+MD5 (Benchmark-Stopwatch-0.03.tar.gz) = 14a58481012db21ad046c718dd3da76c
+SHA256 (Benchmark-Stopwatch-0.03.tar.gz) = 687f9889b97d696de337ec261bda227561322a3f4c0f7060af54a127ed6cbed2
+SIZE (Benchmark-Stopwatch-0.03.tar.gz) = 4731
diff --git a/benchmarks/p5-Benchmark-Stopwatch/pkg-descr b/benchmarks/p5-Benchmark-Stopwatch/pkg-descr
new file mode 100644
index 000000000000..da18320f2de1
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Stopwatch/pkg-descr
@@ -0,0 +1,18 @@
+The other benchmark modules provide excellent timing for specific
+parts of your code. This module aims to allow you to easily time the
+progression of your code.
+
+The stopwatch analogy is that at some point you get a new stopwatch
+and start timing. Then you note certain events using lap. Finally you
+stop the watch and then print out a summary.
+
+The summary shows all the events in order, what time they occured at,
+how long since the last lap and the percentage of the total time.
+Hopefully this will give you a good idea of where your code is
+spending most of its time.
+
+The times are all wallclock times in fractional seconds.
+
+That's it.
+
+WWW: http://search.cpan.org/dist/Benchmark-Stopwatch/
diff --git a/benchmarks/p5-Benchmark-Stopwatch/pkg-plist b/benchmarks/p5-Benchmark-Stopwatch/pkg-plist
new file mode 100644
index 000000000000..9006cf525647
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Stopwatch/pkg-plist
@@ -0,0 +1,3 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Benchmark/Stopwatch.pm
+@dirrmtry %%SITE_PERL%%/Benchmark