aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-11-18 23:37:41 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2004-11-18 23:37:41 +0000
commit9fc8308b46d5b999dbfb1da8dc541a87549bcafc (patch)
treef30410b324a591c74a0b9873f9d26d254fdb45ef /benchmarks
parentbfcbafca2f8d98272a8e7af54d0572b71406cf04 (diff)
downloadports-9fc8308b46d5b999dbfb1da8dc541a87549bcafc.tar.gz
ports-9fc8308b46d5b999dbfb1da8dc541a87549bcafc.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/netperf/Makefile4
-rw-r--r--benchmarks/netperf/distinfo4
-rw-r--r--benchmarks/netperf/files/patch-netlib.c24
-rw-r--r--benchmarks/netperf/files/patch-netlib.h32
-rw-r--r--benchmarks/netperf/files/patch-netperf.c20
-rw-r--r--benchmarks/netperf/files/patch-nettest_bsd.c67
-rw-r--r--benchmarks/netperf/files/patch-nettest_ipv6.c11
-rw-r--r--benchmarks/netperf/files/patch-nettest_unix.c19
8 files changed, 109 insertions, 72 deletions
diff --git a/benchmarks/netperf/Makefile b/benchmarks/netperf/Makefile
index 08e3833dcc7d..ddb59f536567 100644
--- a/benchmarks/netperf/Makefile
+++ b/benchmarks/netperf/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= netperf
-PORTVERSION= 2.2.4
+PORTVERSION= 2.3.1
CATEGORIES= benchmarks ipv6
MASTER_SITES= ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/
-DISTNAME= netperf-2.2pl4
+DISTNAME= netperf-2.3pl1
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= Rick Jones' <raj@cup.hp.com> network performance benchmarking package
diff --git a/benchmarks/netperf/distinfo b/benchmarks/netperf/distinfo
index 8d2d71b1b7fc..70efa2469483 100644
--- a/benchmarks/netperf/distinfo
+++ b/benchmarks/netperf/distinfo
@@ -1,2 +1,2 @@
-MD5 (netperf-2.2pl4.tar.gz) = 0ba938bc65dac4989639a40fdf892952
-SIZE (netperf-2.2pl4.tar.gz) = 823686
+MD5 (netperf-2.3pl1.tar.gz) = b74314d78af31cb13516fb9a372d2e86
+SIZE (netperf-2.3pl1.tar.gz) = 836110
diff --git a/benchmarks/netperf/files/patch-netlib.c b/benchmarks/netperf/files/patch-netlib.c
index c7bcf1e53289..f8f35bdb003c 100644
--- a/benchmarks/netperf/files/patch-netlib.c
+++ b/benchmarks/netperf/files/patch-netlib.c
@@ -1,20 +1,20 @@
---- netlib.c 21 Jan 2003 00:28:51 -0000 1.4
-+++ netlib.c 21 Jan 2003 00:45:01 -0000
-@@ -1414,7 +1414,7 @@
+--- netlib.c.orig Tue Sep 21 22:33:40 2004
++++ netlib.c Fri Nov 5 12:57:14 2004
+@@ -1656,7 +1656,7 @@
dump_request();
fprintf(where,
-- "\nsend_request: about to send %ld bytes from %p\n",
-+ "\nsend_request: about to send %d bytes from %p\n",
- sizeof(netperf_request),
- &netperf_request);
+- "\nsend_request: about to send %ld bytes from %p\n",
++ "\nsend_request: about to send %d bytes from %p\n",
+ sizeof(netperf_request),
+ &netperf_request);
fflush(where);
-@@ -3305,7 +3305,7 @@
+@@ -3887,7 +3887,7 @@
/* program, but that doesn't really seem worthwhile - raj 4/95 */
if (debug > 1) {
fprintf(where,
-- "Looper child %d is born, pid %d\n",
-+ "Looper child %d is born, pid %ld\n",
- child_index,
- getpid());
+- "Looper child %d is born, pid %d\n",
++ "Looper child %d is born, pid %ld\n",
+ child_index,
+ getpid());
fflush(where);
diff --git a/benchmarks/netperf/files/patch-netlib.h b/benchmarks/netperf/files/patch-netlib.h
index 53db171bd155..4cb3f360d9e8 100644
--- a/benchmarks/netperf/files/patch-netlib.h
+++ b/benchmarks/netperf/files/patch-netlib.h
@@ -1,22 +1,22 @@
---- netlib.h 21 Jan 2003 00:26:13 -0000 1.1.1.3
-+++ netlib.h 21 Jan 2003 00:45:02 -0000
-@@ -305,6 +305,7 @@
- extern int dl_open();
- extern char format_cpu_method();
- extern unsigned int convert();
-+extern int delta_micro();
-
- /* these are all for the confidence interval stuff */
- extern double confidence;
-@@ -317,6 +318,11 @@
- #define HAVE_BCOPY
- #define HAVE_BZERO
+--- netlib.h.orig Tue Sep 21 22:33:40 2004
++++ netlib.h Fri Nov 5 12:56:59 2004
+@@ -275,6 +275,11 @@
+ (errno == WSAECONNRESET) ))
#endif
-+
+
+#if defined(__FreeBSD__) || defined(__NetBSD__)
+#define HAVE_BCOPY
+#define HAVE_BZERO
+#endif /* __FreeBSD__ || __NetBSD__ */
++
+ #ifdef HAVE_SENDFILE
+
+ struct sendfile_ring_elt {
+@@ -411,6 +416,7 @@
+ extern int dl_open(char devfile[], int ppa);
+ extern char format_cpu_method(int method);
+ extern unsigned int convert(char *string);
++extern int delta_micro();
- #ifndef HAVE_BCOPY
- #define bcopy(s,d,h) memcpy((d),(s),(h))
+ /* these are all for the confidence interval stuff */
+ extern double confidence;
diff --git a/benchmarks/netperf/files/patch-netperf.c b/benchmarks/netperf/files/patch-netperf.c
index 7959914c6d58..ec823d0b75dc 100644
--- a/benchmarks/netperf/files/patch-netperf.c
+++ b/benchmarks/netperf/files/patch-netperf.c
@@ -1,10 +1,10 @@
---- netperf.c~ Fri Jun 21 22:42:53 2002
-+++ netperf.c Tue Jan 21 00:55:34 2003
-@@ -47,6 +47,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <sys/types.h>
-
- #ifdef WIN32
- #include <windows.h>
+--- netperf.c.orig Tue Sep 21 22:33:40 2004
++++ netperf.c Fri Nov 5 12:58:32 2004
+@@ -50,6 +50,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <strings.h>
++#include <sys/types.h>
+
+ #ifdef WIN32
+ #include <winsock2.h>
diff --git a/benchmarks/netperf/files/patch-nettest_bsd.c b/benchmarks/netperf/files/patch-nettest_bsd.c
index 329e75fbb8da..2b684a1f3cf5 100644
--- a/benchmarks/netperf/files/patch-nettest_bsd.c
+++ b/benchmarks/netperf/files/patch-nettest_bsd.c
@@ -1,22 +1,47 @@
---- nettest_bsd.c 21 Jan 2003 00:26:14 -0000 1.1.1.3
-+++ nettest_bsd.c 21 Jan 2003 00:45:17 -0000
-@@ -58,6 +58,7 @@
- #include <netinet/in.h>
- #include <netinet/tcp.h>
- #include <netdb.h>
-+#include <sys/param.h>
- #else /* WIN32 */
- #include <process.h>
- #include <windows.h>
-@@ -68,6 +69,11 @@
- #include "netlib.h"
- #include "netsh.h"
- #include "nettest_bsd.h"
+--- nettest_bsd.c.orig Tue Sep 21 22:33:40 2004
++++ nettest_bsd.c Thu Nov 18 23:29:38 2004
+@@ -7649,7 +7649,9 @@
+ else {
+ tcp_tran_rr_request->test_length = test_trans * -1;
+ }
+-
++ tcp_tran_rr_request->port = remote_data_port;
++ tcp_tran_rr_request->ipaddress = remote_data_ip;
+
-+#ifdef BSD
-+#include <sys/time.h>
-+#include <arpa/inet.h>
-+#endif /* BSD */
-
- #ifdef HISTOGRAM
- #ifdef __sgi
+ if (debug > 1) {
+ fprintf(where,"netperf: send_tcp_tran_rr: requesting TCP_TRR test\n");
+ }
+@@ -7753,9 +7755,11 @@
+ /* all depends on "reality of programming." keeping it this way is */
+ /* a bit more conservative I imagine - raj 3/95 */
+ send_socket = create_data_socket(AF_INET,
+- SOCK_STREAM);
++ SOCK_STREAM,
++ local_data_ip,
++ local_data_port);
+
+- if (send_socket == INAVLID_SOCKET) {
++ if (send_socket == INVALID_SOCKET) {
+ perror("netperf: send_tcp_tran_rr: tcp stream data socket");
+ exit(1);
+ }
+@@ -8219,7 +8223,9 @@
+ loc_sndavoid = tcp_tran_rr_request->so_sndavoid;
+
+ s_listen = create_data_socket(AF_INET,
+- SOCK_STREAM);
++ SOCK_STREAM,
++ tcp_tran_rr_request->ipaddress,
++ tcp_tran_rr_request->port);
+
+ if (s_listen == INVALID_SOCKET) {
+ netperf_response.content.serv_errno = errno;
+@@ -8438,7 +8444,7 @@
+ send_message_ptr,
+ tcp_tran_rr_request->response_size,
+ MSG_EOF,
+- &peeraddr_in,
++ (struct sockaddr *)&peeraddr_in,
+ sizeof(struct sockaddr_in))) == SOCKET_ERROR) {
+ if (SOCKET_EINTR(bytes_sent)) {
+ /* the test timer has popped */
diff --git a/benchmarks/netperf/files/patch-nettest_ipv6.c b/benchmarks/netperf/files/patch-nettest_ipv6.c
new file mode 100644
index 000000000000..263b49cd1ed1
--- /dev/null
+++ b/benchmarks/netperf/files/patch-nettest_ipv6.c
@@ -0,0 +1,11 @@
+--- nettest_ipv6.c.orig Tue Sep 21 22:33:40 2004
++++ nettest_ipv6.c Thu Nov 18 23:32:10 2004
+@@ -6371,7 +6371,7 @@
+ send_message_ptr,
+ tcpipv6_tran_rr_request->response_size,
+ MSG_EOF,
+- &peeraddr_in,
++ (struct sockaddr *)&peeraddr_in,
+ sizeof(struct sockaddr_in6))) == INVALID_SOCKET) {
+ if (SOCKET_EINTR(bytes_sent)) {
+ /* the test timer has popped */
diff --git a/benchmarks/netperf/files/patch-nettest_unix.c b/benchmarks/netperf/files/patch-nettest_unix.c
index 898c35ab279e..8285c39fdc7b 100644
--- a/benchmarks/netperf/files/patch-nettest_unix.c
+++ b/benchmarks/netperf/files/patch-nettest_unix.c
@@ -1,12 +1,13 @@
---- nettest_unix.c 10 Mar 2001 13:04:39 -0000 1.1.1.2
-+++ nettest_unix.c 21 Jan 2003 00:45:21 -0000
-@@ -45,7 +45,8 @@
+--- nettest_unix.c.orig Thu Nov 18 23:24:22 2004
++++ nettest_unix.c Thu Nov 18 23:26:24 2004
+@@ -52,7 +52,9 @@
#include <string.h>
#include <time.h>
- #include <unistd.h>
--#ifndef __bsdi__
-+#include <sys/param.h>
-+#ifndef BSD
+ #include <sys/time.h>
+-#if ! defined(__bsdi__) && ! defined(_APPLE_)
++#if __FreeBSD__
++#include <stdlib.h>
++#elif ! defined(__bsdi__) && ! defined(_APPLE_)
#include <malloc.h>
- #endif
-
+ #else
+ #include <sys/malloc.h>