aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2006-08-12 15:16:47 +0000
committerStefan Eßer <se@FreeBSD.org>2006-08-12 15:16:47 +0000
commitd028c5bc432aa73157ccc9de91023b9ea3c5a0f8 (patch)
tree68ca13a68f3c30d965f4c50522b29899916032d8 /benchmarks
parente309a114ea4106459515f19abda536e4f982875e (diff)
downloadports-d028c5bc432aa73157ccc9de91023b9ea3c5a0f8.tar.gz
ports-d028c5bc432aa73157ccc9de91023b9ea3c5a0f8.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bonnie/Makefile4
-rw-r--r--benchmarks/unixbench/Makefile24
2 files changed, 14 insertions, 14 deletions
diff --git a/benchmarks/bonnie/Makefile b/benchmarks/bonnie/Makefile
index fc48af66cd7e..8af2fd137ae4 100644
--- a/benchmarks/bonnie/Makefile
+++ b/benchmarks/bonnie/Makefile
@@ -23,7 +23,7 @@ MAN1= bonnie.1
PLIST_FILES= bin/bonnie
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Bonnie ${PREFIX}/bin/bonnie
- ${INSTALL_MAN} ${FILESDIR}/bonnie.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/Bonnie ${TARGETDIR}/bin/bonnie
+ ${INSTALL_MAN} ${FILESDIR}/bonnie.1 ${TARGETDIR}/man/man1
.include <bsd.port.mk>
diff --git a/benchmarks/unixbench/Makefile b/benchmarks/unixbench/Makefile
index 1ec1d523027c..45899ab1ee95 100644
--- a/benchmarks/unixbench/Makefile
+++ b/benchmarks/unixbench/Makefile
@@ -20,34 +20,34 @@ post-extract:
${RM} -f ${WRKSRC}/pgms/select
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/unixbench ${PREFIX}/bin/
- -${MKDIR} ${PREFIX}/lib/unixbench
+ ${INSTALL_SCRIPT} ${WRKDIR}/unixbench ${TARGETDIR}/bin/
+ -${MKDIR} ${TARGETDIR}/lib/unixbench
for f in Run ; do \
- ${INSTALL_SCRIPT} ${WRKSRC}/$${f} ${PREFIX}/lib/unixbench/ ; \
+ ${INSTALL_SCRIPT} ${WRKSRC}/$${f} ${TARGETDIR}/lib/unixbench/ ; \
done
for f in Makefile README ; do \
- ${INSTALL_DATA} ${WRKSRC}/$${f} ${PREFIX}/lib/unixbench/ ; \
+ ${INSTALL_DATA} ${WRKSRC}/$${f} ${TARGETDIR}/lib/unixbench/ ; \
done
- -${MKDIR} ${PREFIX}/lib/unixbench/pgms
+ -${MKDIR} ${TARGETDIR}/lib/unixbench/pgms
for f in ${WRKSRC}/pgms/* ; do \
case $$f in \
*.awk|*.sh|*perlbench) \
- ${INSTALL_SCRIPT} $${f} ${PREFIX}/lib/unixbench/pgms/ ;; \
+ ${INSTALL_SCRIPT} $${f} ${TARGETDIR}/lib/unixbench/pgms/ ;; \
*.logo|*.base) \
- ${INSTALL_SCRIPT} $${f} ${PREFIX}/lib/unixbench/pgms/ ;; \
+ ${INSTALL_SCRIPT} $${f} ${TARGETDIR}/lib/unixbench/pgms/ ;; \
*.orig|*.rej|*~) \
;;\
*) \
- ${INSTALL_PROGRAM} $${f} ${PREFIX}/lib/unixbench/pgms/ ;; \
+ ${INSTALL_PROGRAM} $${f} ${TARGETDIR}/lib/unixbench/pgms/ ;; \
esac ; \
done
- -${MKDIR} ${PREFIX}/lib/unixbench/results
+ -${MKDIR} ${TARGETDIR}/lib/unixbench/results
# for f in ${WRKSRC}/results/* ; do \
-# ${INSTALL_DATA} $${f} ${PREFIX}/lib/unixbench/results/ ; \
+# ${INSTALL_DATA} $${f} ${TARGETDIR}/lib/unixbench/results/ ; \
# done
- -${MKDIR} ${PREFIX}/lib/unixbench/testdir
+ -${MKDIR} ${TARGETDIR}/lib/unixbench/testdir
for f in ${WRKSRC}/testdir/* ; do \
- ${INSTALL_DATA} $${f} ${PREFIX}/lib/unixbench/testdir/ ; \
+ ${INSTALL_DATA} $${f} ${TARGETDIR}/lib/unixbench/testdir/ ; \
done
.include <bsd.port.mk>