aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-07-23 17:21:32 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-07-23 17:21:32 +0000
commit281c742d3ddc979434fc781945f5cbc674a995b5 (patch)
treee90a0936747a5d9aa09f0b6adecde568284326e6 /benchmarks
parentfbd2fd70946c85ce97bd4e48bf64ce5fe14978fc (diff)
downloadports-281c742d3ddc979434fc781945f5cbc674a995b5.tar.gz
ports-281c742d3ddc979434fc781945f5cbc674a995b5.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/flowgrind/Makefile12
-rw-r--r--benchmarks/flowgrind/distinfo4
-rw-r--r--benchmarks/flowgrind/files/patch-fg_socket22
-rw-r--r--benchmarks/flowgrind/files/patch-flowgrind29
4 files changed, 7 insertions, 60 deletions
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index 7f46a8d9bfd6..a59a9a3e9d8a 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -2,17 +2,16 @@
# $FreeBSD$
PORTNAME= flowgrind
-PORTVERSION= 0.6.0
-PORTREVISION= 2
+PORTVERSION= 0.6.1
CATEGORIES= benchmarks
-MASTER_SITES= https://launchpad.net/flowgrind/trunk/${PORTNAME}-0.6/+download/
+MASTER_SITES= https://launchpad.net/flowgrind/trunk/${PORTNAME}-0.6.1/+download/
MAINTAINER= lars@eggert.org
COMMENT= Measure throughput and other metrics for TCP
LIB_DEPENDS= xmlrpc++:${PORTSDIR}/net/xmlrpc-c \
- gsl:${PORTSDIR}/math/gsl
-BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.so:${PORTSDIR}/net/libpcap
+ gsl:${PORTSDIR}/math/gsl \
+ pcap.1:${PORTSDIR}/net/libpcap
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -23,5 +22,4 @@ MAN1= flowgrind-stop.1 \
flowgrind.1 \
flowgrindd.1
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/flowgrind/distinfo b/benchmarks/flowgrind/distinfo
index 53faddc432b2..349be26ceb62 100644
--- a/benchmarks/flowgrind/distinfo
+++ b/benchmarks/flowgrind/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flowgrind-0.6.0.tar.bz2) = 8a4018976cdcd63f304436fa25589687f2e2f1adebc67ee0ab4805efc290497a
-SIZE (flowgrind-0.6.0.tar.bz2) = 213142
+SHA256 (flowgrind-0.6.1.tar.bz2) = a0d0f34dc27b4ede320aac913bb2179fc1a307cfb9d3218b9d64d0aeac8a2cef
+SIZE (flowgrind-0.6.1.tar.bz2) = 211922
diff --git a/benchmarks/flowgrind/files/patch-fg_socket b/benchmarks/flowgrind/files/patch-fg_socket
deleted file mode 100644
index cfb25f25bfd0..000000000000
--- a/benchmarks/flowgrind/files/patch-fg_socket
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/fg_socket.h 2013-07-02 14:09:06.000000000 +0200
-+++ src/fg_socket.h.orig 2013-07-02 14:07:20.000000000 +0200
-@@ -19,7 +19,7 @@
- int set_so_lcd(int fd);
- int set_tcp_mtcp(int fd);
- int set_tcp_nodelay(int fd);
--int set_dscp(int sock, uint8_t dscp);
-+int set_dscp(int sock, int dscp);
- int set_tcp_cork(int fd);
- int toggle_tcp_cork(int fd);
- int set_window_size(int, int);
---- src/fg_socket.c 2013-07-02 14:07:12.000000000 +0200
-+++ src/fg_socket.c.orig 2013-07-02 14:06:41.000000000 +0200
-@@ -132,7 +132,7 @@
- return send < receive? send: receive;
- }
-
--int set_dscp(int fd, uint8_t dscp)
-+int set_dscp(int fd, int dscp)
- {
- int optname = IP_TOS;
- int optlevel = IPPROTO_IP;
diff --git a/benchmarks/flowgrind/files/patch-flowgrind b/benchmarks/flowgrind/files/patch-flowgrind
deleted file mode 100644
index 89074e2d4d35..000000000000
--- a/benchmarks/flowgrind/files/patch-flowgrind
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/flowgrind.c
-+++ src/flowgrind.c
-@@ -1872,7 +1872,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
-
- if (extra_rpc) {
- /* Now it's getting tricky... */
-- /* 1st case: IPv6 with port, e.g. "[a:b::c]a:5999" */
-+ /* 1st case: IPv6 with port, e.g. "[a:b::c]:5999" */
- if ((sepptr = strchr(rpc_address, ']'))) {
- is_ipv6 = 1;
- *sepptr = '\0';
-@@ -1884,7 +1884,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
- port = atoi(sepptr);
- } else if ((sepptr = strchr(rpc_address, ':'))) {
- /* 2nd case: IPv6 without port, e.g. "a:b::c" */
-- if (strchr(sepptr, ':')) {
-+ if (strchr(sepptr+1, ':')) {
- is_ipv6 = 1;
- } else {
- /* 3rd case: IPv4 or name with port 1.2.3.4:5999*/
-@@ -1910,7 +1910,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
- fprintf(stderr, "No test host given in argument\n");
- usage();
- }
-- if (is_ipv6)
-+ if (is_ipv6)
- sprintf(url, "http://[%s]:%d/RPC2", rpc_address, port);
- else
- sprintf(url, "http://%s:%d/RPC2", rpc_address, port);