aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-30 23:09:05 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-30 23:09:05 +0000
commitad1bf8ec5ac5f7d7c23652030c3cdef190cc4416 (patch)
tree9d941c6dc7a53925f086370ffd2d963668701603 /benchmarks
parentceed245e05e1a5376beda6ecbf3ca3f2c2ddba56 (diff)
downloadports-ad1bf8ec5ac5f7d7c23652030c3cdef190cc4416.tar.gz
ports-ad1bf8ec5ac5f7d7c23652030c3cdef190cc4416.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/polygraph/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index 3a541f113f31..116b9bd1a3b6 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -24,25 +24,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFLICTS= ltrace-0*
OPTIONS_DEFINE= GNUPLOT OPENSSL PERL ZLIB
+OPTIONS_DEFAULT=OPENSSL ZLIB
GNUPLOT_DESC= GNUPlot for full reporting functionality
OPENSSL_DESC= Enable SSL/HTTPS support
PERL_DESC= Install Perl for PolyGraph tools
ZLIB_DESC= Enable HTTP compression support
-OPTIONS_DEFAULT= OPENSSL ZLIB
-
-GNUPLOT_RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
-
+GNUPLOT_RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
OPENSSL_USE= OPENSSL=yes
+OPENSSL_CONFIGURE_ON= --with-ssl=${OPENSSLBASE}
PERL_USES= perl5
PERL_USE= PERL5=run
ZLIB_CONFIGURE_WITH= zlib=/usr
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
-.endif
-
.include <bsd.port.mk>