aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-06-18 10:47:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-06-18 10:47:08 +0000
commit2660f907676e67568a96d909eb84836355d8d534 (patch)
treed0f06cb19ac2bf48b25523f3f894cb1fa042866d /benchmarks
parenteee8278a3f0e1b200ff29eac73e106ecc6ae9f74 (diff)
downloadports-2660f907676e67568a96d909eb84836355d8d534.tar.gz
ports-2660f907676e67568a96d909eb84836355d8d534.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/polygraph31/Makefile10
2 files changed, 7 insertions, 4 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index d5effb477f45..ebdecdd20219 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -41,6 +41,7 @@
SUBDIR += pipebench
SUBDIR += pnetmark
SUBDIR += polygraph
+ SUBDIR += polygraph31
SUBDIR += postal
SUBDIR += postmark
SUBDIR += pybench
diff --git a/benchmarks/polygraph31/Makefile b/benchmarks/polygraph31/Makefile
index d4058b605bbe..71f2a4fb4fbc 100644
--- a/benchmarks/polygraph31/Makefile
+++ b/benchmarks/polygraph31/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= polygraph
+PORTNAME= polygraph31
PORTVERSION= 3.0.6
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/ \
http://people.bsdgroup.de/~as/freebsd/distfiles/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTNAME= ${PORTNAME:S/31//}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
MAINTAINER= as@bsdgroup.de
@@ -19,15 +19,17 @@ COMMENT= A benchmarking tool for Web proxies
GNU_CONFIGURE= YES
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
CONFIGURE_ARGS+=--datadir=${DATADIR}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME:S/31//}-${PORTVERSION}
-CONFLICTS= ltrace-0*
+CONFLICTS= ltrace-0* polygraph-[0-9]*
OPTIONS= GNUPLOT "gnuplot if you want full report functionality" ON \
PERL "install Perl for polygraph tools" OFF
.include <bsd.port.pre.mk>
+DATADIR:= ${DATADIR:S/31//}
+
.if !defined(WITHOUT_GNUPLOT)
RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
.endif