aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-12-11 13:56:12 +0000
committerSimon Barner <barner@FreeBSD.org>2005-12-11 13:56:12 +0000
commita1a5e898821562717b6c3422a7ad228ffdee2c7b (patch)
tree0cd63b37ae4acf66424149b3cb1197a38b569e3d /benchmarks
parent1a8ddf1a5a59c009dcb5bb100f281105500a8f6d (diff)
downloadports-a1a5e898821562717b6c3422a7ad228ffdee2c7b.tar.gz
ports-a1a5e898821562717b6c3422a7ad228ffdee2c7b.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/sysbench/Makefile41
-rw-r--r--benchmarks/sysbench/distinfo3
-rw-r--r--benchmarks/sysbench/pkg-descr21
-rw-r--r--benchmarks/sysbench/pkg-plist3
5 files changed, 69 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index b91c9e2e41d9..355d6bfe97be 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -43,6 +43,7 @@
SUBDIR += siege
SUBDIR += stream
SUBDIR += super-smack
+ SUBDIR += sysbench
SUBDIR += tcpblast
SUBDIR += thrulay
SUBDIR += tmetric
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
new file mode 100644
index 000000000000..0087cf823a35
--- /dev/null
+++ b/benchmarks/sysbench/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: sysbench
+# Date created: 2005-12-11
+# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysbench
+PORTVERSION= 0.4.3
+CATEGORIES= benchmarks databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+COMMENT= A modular, cross-platform and multi-threaded benchmark tool
+
+GNU_CONFIGURE= yes
+
+OPTIONS= MYSQL "Enable MySQL support" on \
+ POSTGRESQL "Enable PostgreSQL support" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= --with-mysql
+.endif
+
+.if defined(WITH_POSTGRESQL)
+USE_PGSQL= yes
+WANT_PGSQL_VER?= 80
+CONFIGURE_ARGS+= --with-pgsql
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sysbench/sysbench ${PREFIX}/bin
+.for FILE in sb_run.sh sb_test_ps.sh
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/${FILE} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/benchmarks/sysbench/distinfo b/benchmarks/sysbench/distinfo
new file mode 100644
index 000000000000..9941163c4f48
--- /dev/null
+++ b/benchmarks/sysbench/distinfo
@@ -0,0 +1,3 @@
+MD5 (sysbench-0.4.3.tar.gz) = 34ad20419aeeba78363a340d58ebca3a
+SHA256 (sysbench-0.4.3.tar.gz) = 09ed77a640aa6bbcdf11430c9d4de1f6b7faf69dab54899ff5d5c957e40298d3
+SIZE (sysbench-0.4.3.tar.gz) = 480318
diff --git a/benchmarks/sysbench/pkg-descr b/benchmarks/sysbench/pkg-descr
new file mode 100644
index 000000000000..d98c49605282
--- /dev/null
+++ b/benchmarks/sysbench/pkg-descr
@@ -0,0 +1,21 @@
+SysBench is a modular, cross-platform and multi-threaded benchmark tool
+for evaluating OS parameters that are important for a system running a
+database under intensive load.
+
+The idea of this benchmark suite is to quickly get an impression about
+system performance without setting up complex database benchmarks or
+even without installing a database at all.
+
+Current features allow to test the following system parameters:
+
+ * file I/O performance
+ * scheduler performance
+ * memory allocation and transfer speed
+ * POSIX threads implementation performance
+ * database server performance (OLTP benchmark)
+
+Primarily written for MySQL server benchmarking, SysBench will be
+further extended to support multiple database backends, distributed
+benchmarks and third-party plug-in modules.
+
+WWW: http://sysbench.sourceforge.net/
diff --git a/benchmarks/sysbench/pkg-plist b/benchmarks/sysbench/pkg-plist
new file mode 100644
index 000000000000..22cfe41ebdbc
--- /dev/null
+++ b/benchmarks/sysbench/pkg-plist
@@ -0,0 +1,3 @@
+bin/sb_run.sh
+bin/sb_test_ps.sh
+bin/sysbench