aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-11-13 23:17:48 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-11-13 23:17:48 +0000
commit735f2f97add084198eee97a36c9c637a3bfe799f (patch)
treea163821ce1755b30941ece29a7d0b843d0550f6f /benchmarks
parent2610e190bd7d80a18a398f398e4e75232827108e (diff)
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iozone/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index e5bccfcbbbdd..370840a3873f 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: iozone
-# Date created: 26 September 1994
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= iozone
PORTVERSION= 3.397
@@ -27,29 +23,29 @@ MAKE_JOBS_UNSAFE= yes
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on \
- SSH "Use ssh in distributed measurement" on
+OPTIONS_DEFINE= SSH THREADS
+OPTIONS_DEFAULT=SSH THREADS
-.include <bsd.port.pre.mk>
+SSH_DESC= Use ssh in distributed measurement
+THREADS_DESC= Enable threading (uses pthreads)
-.if defined (WITH_THREADS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTHREADS}
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
.else
-CFLAGS+=-DNO_THREADS
+CFLAGS+= -DNO_THREADS
.endif
-.if defined (WITH_SSH)
-post-patch::
+post-patch:
+.if ${PORT_OPTIONS:MSSH}
@${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
.endif
-
-post-patch::
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/makefile
do-install:
- ${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${MANPREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>