aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-01 18:57:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-01 18:57:02 +0000
commitcd162d2197280d8f4be68fac422f654673ab31bd (patch)
treec87b09666c9afb68b9d71fe97ef7304c3e5b053d /benchmarks
parent09c57f862ba57cc4857066a686924f29033b96e4 (diff)
downloadports-cd162d2197280d8f4be68fac422f654673ab31bd.tar.gz
ports-cd162d2197280d8f4be68fac422f654673ab31bd.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iperf/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index 4e9da8b15228..452a02711d22 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -7,41 +7,39 @@
PORTNAME= iperf
PORTVERSION= 2.0.5
-CATEGORIES= benchmarks ipv6
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=${PORTNAME}
+CATEGORIES= benchmarks
+MASTER_SITES= SF/${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A tool to measure maximum TCP and UDP bandwidth
+OPTIONS= IPV6 "Enable support to IPv6" on \
+ THREADS "Enable threads support" on
+
GNU_CONFIGURE= yes
-PLIST_FILES= bin/iperf
MAN1= iperf.1
+PLIST_FILES= bin/iperf
PORTDOCS= *
-OPTIONS= IPV6 "Enable support to IPv6" on \
- THREADS "Enable threads support" on
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
+CONFIGURE_ARGS+=--disable-ipv6
+.else
+CATEGORIES+= ipv6
.endif
.if defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --disable-threads
+CONFIGURE_ARGS+=--disable-threads
.else
-CFLAGS+= ${PTHREAD_LIBS}
+LDFLAGS+= ${PTHREAD_LIBS}
.endif
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.for f in ${WRKSRC}/doc/*.html ${WRKSRC}/doc/*.gif
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/doc/*.gif ${WRKSRC}/doc/*.html ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>