aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2010-08-23 11:20:59 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2010-08-23 11:20:59 +0000
commit0777d56570660c8e7ec397174e9a1d60a6fec432 (patch)
treeeda10ac9ec773042213d97521922777fa374c667 /benchmarks
parentf0e7d21442dfdcc24a6c15a88e6a63634f99ca69 (diff)
downloadports-0777d56570660c8e7ec397174e9a1d60a6fec432.tar.gz
ports-0777d56570660c8e7ec397174e9a1d60a6fec432.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/randomio/Makefile23
-rw-r--r--benchmarks/randomio/distinfo3
-rw-r--r--benchmarks/randomio/files/patch-Makefile8
-rw-r--r--benchmarks/randomio/pkg-descr4
5 files changed, 39 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index e25fa3b27d57..99fdb1aff186 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -50,6 +50,7 @@
SUBDIR += postmark
SUBDIR += pybench
SUBDIR += raidtest
+ SUBDIR += randomio
SUBDIR += rawio
SUBDIR += rubygem-railsbench
SUBDIR += scimark2
diff --git a/benchmarks/randomio/Makefile b/benchmarks/randomio/Makefile
new file mode 100644
index 000000000000..ae763adaccc8
--- /dev/null
+++ b/benchmarks/randomio/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: randomio
+# Date created: 20 Aug 2010
+# Whom: Sergey Kandaurov <pluknet@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= randomio
+PORTVERSION= 1.4
+CATEGORIES= benchmarks
+MASTER_SITES= http://www.arctic.org/~dean/randomio/
+
+MAINTAINER= pluknet@gmail.com
+COMMENT= A multithreaded disk i/o microbenchmark
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/benchmarks/randomio/distinfo b/benchmarks/randomio/distinfo
new file mode 100644
index 000000000000..dc68e26a1fd0
--- /dev/null
+++ b/benchmarks/randomio/distinfo
@@ -0,0 +1,3 @@
+MD5 (randomio-1.4.tar.bz2) = df8cd74b234045c001ce93fef0abb75b
+SHA256 (randomio-1.4.tar.bz2) = 384da98a7d3da1df2a1bffb9fb499fce6d043588bbf225673fda028bdfd2386f
+SIZE (randomio-1.4.tar.bz2) = 4249
diff --git a/benchmarks/randomio/files/patch-Makefile b/benchmarks/randomio/files/patch-Makefile
new file mode 100644
index 000000000000..42d608d1bee0
--- /dev/null
+++ b/benchmarks/randomio/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig 2010-08-20 19:36:08.000000000 +0400
++++ Makefile 2010-08-20 19:39:25.000000000 +0400
+@@ -5,3 +5,5 @@
+
+ clean:
+ rm -f *.o randomio
++
++all: randomio
diff --git a/benchmarks/randomio/pkg-descr b/benchmarks/randomio/pkg-descr
new file mode 100644
index 000000000000..7b0d9dd791d2
--- /dev/null
+++ b/benchmarks/randomio/pkg-descr
@@ -0,0 +1,4 @@
+Randomio is a multithreaded disk i/o microbenchmark. It
+requires O_DIRECT, pread/pwrite, and pthreads.
+
+WWW: http://www.arctic.org/~dean/randomio/