aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-04-29 08:56:26 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-07 02:40:01 +0000
commit9e9d84f60dbe5c74c3ea03dff185ce22eba69a96 (patch)
treebe0e32646104bc4567e942d6fc9b0a8733561ff5 /benchmarks
parent1684f47e9bea7c1d47924756d545871276bb0581 (diff)
downloadports-9e9d84f60dbe5c74c3ea03dff185ce22eba69a96.tar.gz
ports-9e9d84f60dbe5c74c3ea03dff185ce22eba69a96.zip
benchmarks/vkpeak: add new port
vkpeak is a synthetic benchmarking tool to measure peak capabilities of Vulkan devices. It only measures the peak metrics that can be achieved using vector operations and does not represent a real-world use case. https://github.com/nihui/vkpeak
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/vkpeak/Makefile25
-rw-r--r--benchmarks/vkpeak/distinfo7
-rw-r--r--benchmarks/vkpeak/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 71f2f9bbe3d4..d45d58ee2676 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -102,6 +102,7 @@
SUBDIR += uperf
SUBDIR += vegeta
SUBDIR += vkmark
+ SUBDIR += vkpeak
SUBDIR += webbench
SUBDIR += wrk
diff --git a/benchmarks/vkpeak/Makefile b/benchmarks/vkpeak/Makefile
new file mode 100644
index 000000000000..29073192b93c
--- /dev/null
+++ b/benchmarks/vkpeak/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= vkpeak
+DISTVERSION= 20210430
+CATEGORIES= benchmarks
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Profile Vulkan devices to find their peak capacities
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
+
+USES= cmake compiler:c++11-lib
+USE_GITHUB= yes
+GH_ACCOUNT= nihui
+GH_TUPLE= KhronosGroup:glslang:11.1.0-44-g4afd6917:nglslang/ncnn/glslang \
+ Tencent:ncnn:20210322-66-g45bf3cd7:ncnn/ncnn
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/benchmarks/vkpeak/distinfo b/benchmarks/vkpeak/distinfo
new file mode 100644
index 000000000000..3eccbbf3fd50
--- /dev/null
+++ b/benchmarks/vkpeak/distinfo
@@ -0,0 +1,7 @@
+TIMESTAMP = 1619686586
+SHA256 (nihui-vkpeak-20210430_GH0.tar.gz) = e9f8ff4ca5f4552a1648832738248bad4ec7d1efdb2c6f739f031165d1e63490
+SIZE (nihui-vkpeak-20210430_GH0.tar.gz) = 7374
+SHA256 (KhronosGroup-glslang-11.1.0-44-g4afd6917_GH0.tar.gz) = 5ec414384bafcac14d096ca20205f811b61caf287ea1f7c30745735e7f483ae6
+SIZE (KhronosGroup-glslang-11.1.0-44-g4afd6917_GH0.tar.gz) = 3296291
+SHA256 (Tencent-ncnn-20210322-66-g45bf3cd7_GH0.tar.gz) = 4920ff13322ed31389791cc0313f8d21d3b6ca1a599fbca2f4c0da41bed204f3
+SIZE (Tencent-ncnn-20210322-66-g45bf3cd7_GH0.tar.gz) = 11417411
diff --git a/benchmarks/vkpeak/pkg-descr b/benchmarks/vkpeak/pkg-descr
new file mode 100644
index 000000000000..dbe0d7e154b0
--- /dev/null
+++ b/benchmarks/vkpeak/pkg-descr
@@ -0,0 +1,6 @@
+vkpeak is a synthetic benchmarking tool to measure peak capabilities
+of Vulkan devices. It only measures the peak metrics that can be
+achieved using vector operations and does not represent a real-world
+use case.
+
+WWW: https://github.com/nihui/vkpeak