aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-02-18 12:26:26 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-02-18 12:26:26 +0000
commitbb410056aae470f98b86b017a8e94bd5be807f51 (patch)
tree678ec3d87862660050f8a7d46d6cfa27f9a33017 /benchmarks
parent808556826efab4f2d6006ad0f8c00f1b33ab7ce9 (diff)
downloadports-bb410056aae470f98b86b017a8e94bd5be807f51.tar.gz
ports-bb410056aae470f98b86b017a8e94bd5be807f51.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile2
-rw-r--r--benchmarks/sipp/files/patch-sipp.hpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index c79e5fbf15b0..0aadbb5aaa58 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -21,7 +21,7 @@ MAN1= sipp.1
.include <bsd.port.pre.mk>
-.if ((${ARCH} == "alpha") || (${ARCH} == "ia64"))
+.if ${ARCH} == "ia64"
BROKEN= "Does not compile - patch needed by someone who can test it"
.endif
diff --git a/benchmarks/sipp/files/patch-sipp.hpp b/benchmarks/sipp/files/patch-sipp.hpp
new file mode 100644
index 000000000000..4c39f89eb72e
--- /dev/null
+++ b/benchmarks/sipp/files/patch-sipp.hpp
@@ -0,0 +1,11 @@
+--- sipp.hpp.orig Tue Feb 1 15:12:35 2005
++++ sipp.hpp Tue Feb 1 15:12:49 2005
+@@ -268,7 +268,7 @@
+ void pollset_remove(int idx);
+ int pollset_add(call * p_call, int socket);
+
+-#if defined (__hpux) || defined (__alpha)
++#if defined (__hpux)
+ #define sipp_socklen_t int
+ #else
+ #define sipp_socklen_t socklen_t