aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-04-16 11:48:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-04-16 11:48:02 +0000
commit02c202524bd18909a66f3cbf4348f0a2972877dc (patch)
tree9d2b7f43594fb069f56f854736224437344d9f51 /benchmarks
parent1121299f31cd2ec70f4e5a2299ec1d7539dee961 (diff)
downloadports-02c202524bd18909a66f3cbf4348f0a2972877dc.tar.gz
ports-02c202524bd18909a66f3cbf4348f0a2972877dc.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/libmicro/Makefile8
-rw-r--r--benchmarks/libmicro/files/extra-patch-ucontext38
2 files changed, 1 insertions, 45 deletions
diff --git a/benchmarks/libmicro/Makefile b/benchmarks/libmicro/Makefile
index ed7bf0503ea6..ef8186054469 100644
--- a/benchmarks/libmicro/Makefile
+++ b/benchmarks/libmicro/Makefile
@@ -22,12 +22,6 @@ PLIST_SUB= ARCH=${ARCH}
# Do not strip binaries
STRIP=
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 500036
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-ucontext
-.endif
-
do-install:
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/bin
@@ -43,4 +37,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/libmicro-bench ${PREFIX}/bin/libmicro-bench
${INSTALL_SCRIPT} ${WRKSRC}/multiview ${PREFIX}/bin/multiview
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/libmicro/files/extra-patch-ucontext b/benchmarks/libmicro/files/extra-patch-ucontext
deleted file mode 100644
index 2b2f934f9cde..000000000000
--- a/benchmarks/libmicro/files/extra-patch-ucontext
+++ /dev/null
@@ -1,38 +0,0 @@
---- setcontext.c.orig Sat Aug 6 16:18:46 2005
-+++ setcontext.c Sat Aug 6 16:19:29 2005
-@@ -57,7 +57,7 @@
- benchmark(void *tsd, result_t *res)
- {
- volatile int i;
--
-+#if 0
- ucontext_t uc;
-
- i = 0;
-@@ -68,6 +68,7 @@
- (void) setcontext(&uc);
-
- res->re_count += lm_optB;
-+#endif
-
- return (0);
- }
---- getcontext.c.orig Sat Aug 6 16:18:39 2005
-+++ getcontext.c Sat Aug 6 16:19:06 2005
-@@ -59,7 +59,7 @@
- benchmark(void *tsd, result_t *res)
- {
- int i;
--
-+#if 0
- for (i = 0; i < lm_optB; i += 10) {
- ucontext_t uc;
- (void) getcontext(&uc);
-@@ -74,6 +74,6 @@
- (void) getcontext(&uc);
- }
- res->re_count = i;
--
-+#endif
- return (0);
- }