aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 01:05:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 01:05:11 +0000
commitc8ed1b46b4018bdedb0b795fee575bcbf23ce164 (patch)
tree4f86982f178584deb41a86896b6d6107aa984f0d /benchmarks
parent28c38c646c769e7254d173445b468f87da9d2ff0 (diff)
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/pipebench/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/benchmarks/pipebench/Makefile b/benchmarks/pipebench/Makefile
index 7985914f22ea..fc40a616e338 100644
--- a/benchmarks/pipebench/Makefile
+++ b/benchmarks/pipebench/Makefile
@@ -9,18 +9,17 @@ MASTER_SITES= ftp://ftp.habets.pp.se/pub/synscan/
MAINTAINER= mich@FreeBSD.org
COMMENT= Pipebench shows current throughput/amount of data through a pipe
+PLIST_FILES= bin/pipebench \
+ man/man1/pipebench.1.gz
+
CFLAGS+= -w -pedantic
-NO_STAGE= yes
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${PREFIX}/man/man1
-
-MAN1= pipebench.1
-PLIST_FILES= bin/pipebench
+ ${INSTALL_PROGRAM} ${WRKSRC}/pipebench ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pipebench.1 ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>