aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-15 17:21:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-15 17:21:40 +0000
commitd138bdf084f928b4551dd32e8eef32876525326c (patch)
treebd3fa8fa93390c4daf251681805d82f6cd10b38d /benchmarks
parent1c2362cd0bcaa77ff0309f66bd2427061b451eb7 (diff)
downloadports-d138bdf084f928b4551dd32e8eef32876525326c.tar.gz
ports-d138bdf084f928b4551dd32e8eef32876525326c.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/iorate/Makefile41
-rw-r--r--benchmarks/iorate/distinfo2
-rw-r--r--benchmarks/iorate/files/patch-ior_mach.c40
-rw-r--r--benchmarks/iorate/files/patch-ior_mach.h36
-rw-r--r--benchmarks/iorate/pkg-descr8
-rw-r--r--benchmarks/iorate/pkg-plist23
7 files changed, 151 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index c6e924d068ef..12b546f86db9 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -26,6 +26,7 @@
SUBDIR += httperf
SUBDIR += imb
SUBDIR += interbench
+ SUBDIR += iorate
SUBDIR += iozone
SUBDIR += iozone21
SUBDIR += iperf
diff --git a/benchmarks/iorate/Makefile b/benchmarks/iorate/Makefile
new file mode 100644
index 000000000000..7b1ab683b042
--- /dev/null
+++ b/benchmarks/iorate/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= iorate
+PORTVERSION= 3.05
+CATEGORIES= benchmarks
+MASTER_SITES= http://sites.google.com/site/vwiorate/downloads/3-05/
+DISTNAME= iorate-${PORTVERSION}-src
+EXTRACT_SUFX= .tar
+
+MAINTAINER= blttll@gmail.com
+COMMENT= General purpose storage I/O benchmarking tool
+
+USES= bison
+FETCH_ARGS= -Fpr
+MAKEFILE= makefile
+MAKE_ARGS= CC="${CC}"
+NO_WRKSUBDIR= yes
+
+MAN1= ${PORTNAME}.1
+PORTDOCS= README README.versions
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CFLAGS ,&+,' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iorate ${WRKSRC}/ior_rand ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/cycle ${WRKSRC}/gen_* ${WRKSRC}/run_* \
+ ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ior ${DATADIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/iorate/distinfo b/benchmarks/iorate/distinfo
new file mode 100644
index 000000000000..912a516acbb3
--- /dev/null
+++ b/benchmarks/iorate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (iorate-3.05-src.tar) = 6305413dc3ac7d833b0e4d99e30ac6cfd67b2f943b758166a3661c8f96b2480e
+SIZE (iorate-3.05-src.tar) = 460800
diff --git a/benchmarks/iorate/files/patch-ior_mach.c b/benchmarks/iorate/files/patch-ior_mach.c
new file mode 100644
index 000000000000..3e4e17e7dd6b
--- /dev/null
+++ b/benchmarks/iorate/files/patch-ior_mach.c
@@ -0,0 +1,40 @@
+--- ior_mach.c_orig 2013-01-27 02:03:38.000000000 +0200
++++ ior_mach.c 2013-01-27 04:52:47.000000000 +0200
+@@ -411,6 +411,10 @@
+ };
+
+ #else
++#if defined(IOR_LARGE_FILES) && defined(__FreeBSD__)
++#define IOR_SET_LOCK_FLAG F_SETLK
++ struct flock d_lock; /* lock command to run */
++#else
+ #ifdef IOR_LARGE_FILES
+ #define IOR_SET_LOCK_FLAG F_SETLK64
+ struct flock64 d_lock; /* lock command to run */
+@@ -418,6 +422,7 @@
+ #define IOR_SET_LOCK_FLAG F_SETLK
+ struct flock d_lock; /* lock command to run */
+ #endif
++#endif
+
+ result = 0; /* all OK so far */
+
+@@ -486,6 +491,10 @@
+ };
+
+ #else
++#if defined(IOR_LARGE_FILES) && defined(__FreeBSD__)
++#define IOR_SET_LOCK_FLAG F_SETLK
++ struct flock d_lock; /* lock command to run */
++#else
+ #ifdef IOR_LARGE_FILES
+ #define IOR_SET_LOCK_FLAG F_SETLK64
+ struct flock64 d_lock; /* lock command to run */
+@@ -493,6 +502,7 @@
+ #define IOR_SET_LOCK_FLAG F_SETLK
+ struct flock d_lock; /* lock command to run */
+ #endif
++#endif
+
+ result = 0; /* all OK so far */
+
diff --git a/benchmarks/iorate/files/patch-ior_mach.h b/benchmarks/iorate/files/patch-ior_mach.h
new file mode 100644
index 000000000000..4d1f0cd73cff
--- /dev/null
+++ b/benchmarks/iorate/files/patch-ior_mach.h
@@ -0,0 +1,36 @@
+--- ior_mach.h_orig 2013-01-27 01:03:32.000000000 +0200
++++ ior_mach.h 2013-01-27 01:53:51.000000000 +0200
+@@ -142,7 +142,6 @@
+ #define IOR_MAX_SEEK (HUGE)(4398046511104LL) /* 4 TB */
+ #endif
+
+-
+ /************************ OS is LINUX? ************************/
+ /*
+ * Since RedHat uses their own version, check for it
+@@ -203,6 +202,16 @@
+ #endif
+
+
++/************************ OS is FreeBSD? ***********************/
++#ifdef __FreeBSD__
++#include <unistd.h>
++#ifdef IOR_LARGE_FILES
++#define HUGE __off_t
++#define IOR_SEEK lseek
++#define IOR_MAX_SEEK (HUGE)(4398046511104LL) /* 4 TB */
++#endif
++#endif
++
+ /************************ OS is unknown? ************************/
+ /*
+ * OK, not a known type, or did not set up large file support
+@@ -240,7 +249,7 @@
+ /*
+ * process exit status
+ */
+-#if defined( _AIX ) || defined( HPUX ) || defined( __CYGWIN__ )
++#if defined( _AIX ) || defined( HPUX ) || defined( __CYGWIN__ ) || defined(__FreeBSD__)
+ #include <sys/wait.h>
+ #else
+ #include <wait.h>
diff --git a/benchmarks/iorate/pkg-descr b/benchmarks/iorate/pkg-descr
new file mode 100644
index 000000000000..563db4f6b847
--- /dev/null
+++ b/benchmarks/iorate/pkg-descr
@@ -0,0 +1,8 @@
+Iorate is a general purpose storage I/O benchmarking tool.
+
+Iorate was created in 1997 by Vince Westin of EMC while working with Cliff
+Burrell of FedEx to fill a need to perform a set of storage I/O benchmarks.
+Though Iorate was developed by EMC staff with EMC resources there are no
+EMC-specific pieces to the testing, it just tests storage.
+
+WWW: http://iorate.org/
diff --git a/benchmarks/iorate/pkg-plist b/benchmarks/iorate/pkg-plist
new file mode 100644
index 000000000000..e41f6c3c5342
--- /dev/null
+++ b/benchmarks/iorate/pkg-plist
@@ -0,0 +1,23 @@
+bin/ior_rand
+bin/iorate
+%%DATADIR%%/cycle
+%%DATADIR%%/devices.ior
+%%DATADIR%%/gen_dev.awk
+%%DATADIR%%/gen_devs
+%%DATADIR%%/gen_iops
+%%DATADIR%%/gen_iops.awk
+%%DATADIR%%/gen_stats
+%%DATADIR%%/gen_stats.awk
+%%DATADIR%%/gen_sum.awk
+%%DATADIR%%/gen_sums
+%%DATADIR%%/gen_totals
+%%DATADIR%%/gen_totals.awk
+%%DATADIR%%/patterns.ior
+%%DATADIR%%/run_ast
+%%DATADIR%%/run_test
+%%DATADIR%%/run_var
+%%DATADIR%%/tests-ast.ior
+%%DATADIR%%/tests-fx.ior
+%%DATADIR%%/tests-var.ior
+%%DATADIR%%/tests.ior
+@dirrm %%DATADIR%%