aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-19 05:08:04 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-19 05:08:04 +0000
commit12e894e605e6a95e338042cd08c23450c281e858 (patch)
tree49c4f75f589a86af3817ff5dd686363236b9c9d2 /benchmarks
parent41afca14ff1bba954f14937a07f4d49bd0fef717 (diff)
downloadports-12e894e605e6a95e338042cd08c23450c281e858.tar.gz
ports-12e894e605e6a95e338042cd08c23450c281e858.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/pybench/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index 37b52dbb59f4..d9d233bbffde 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pybench
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= benchmarks python
MASTER_SITES= http://downloads.egenix.com/python/
@@ -11,10 +12,16 @@ COMMENT= Extensible benchmark suite for Python
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= python zip
+USES= python shebangfix zip
+SHEBANG_FILES= platform.py
PORTDOCS= README
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/python -O|${python_CMD}|' \
+ ${WRKSRC}/pybench.py
+ @${FIND} ${WRKSRC} -name \*.bak -delete
+
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}