aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-18 11:25:28 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-18 11:25:28 +0000
commit2fe7aa5543ed072690aaa59098e348a9cd165e8f (patch)
treef9c0ac15fac8d6e328e0ede13b5227fce3975751 /benchmarks
parentd7bde1171d0c158ec7be27bf71a8199a3e3ec409 (diff)
downloadports-2fe7aa5543ed072690aaa59098e348a9cd165e8f.tar.gz
ports-2fe7aa5543ed072690aaa59098e348a9cd165e8f.zip
benchmarks/super-smack: fix build on GCC architectures
GCC from ports is required: /usr/local/lib/mysql/libmysqlclient.so: undefined reference to `operator delete(void*, unsigned long)@CXXABI_1.3.9' Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=506848
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/super-smack/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/benchmarks/super-smack/Makefile b/benchmarks/super-smack/Makefile
index affe6cd681a6..a76dad7f380c 100644
--- a/benchmarks/super-smack/Makefile
+++ b/benchmarks/super-smack/Makefile
@@ -25,6 +25,7 @@ OPTIONS_MULTI_DB= MYSQL PGSQL
OPTIONS_DEFAULT= MYSQL
MYSQL_USE= MYSQL=yes
+MYSQL_USES= compiler:c++11-lang
MYSQL_CONFIGURE_ON= --with-mysql \
--with-mysql-include=${LOCALBASE}/include/mysql \
--with-mysql-lib=${LOCALBASE}/lib/mysql