aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2019-09-05 20:16:56 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2019-09-05 20:16:56 +0000
commit7b769dc632fb8828b0618aa8f4cde1f9011fd017 (patch)
tree68fad202c764c71751abf7be79ad4be7bf06dda7 /benchmarks
parent6f079122ce02483af71098df908d9b57eb4204d9 (diff)
downloadports-7b769dc632fb8828b0618aa8f4cde1f9011fd017.tar.gz
ports-7b769dc632fb8828b0618aa8f4cde1f9011fd017.zip
Update to 1.98 and fix type conversion warnings
PR: 210855 Submitted by: Mark Millard <marklmi26-fbsd@yahoo.com> Reviewed by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at>
Notes
Notes: svn path=/head/; revision=511264
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bonnie++/Makefile6
-rw-r--r--benchmarks/bonnie++/distinfo6
-rw-r--r--benchmarks/bonnie++/files/patch-bon_time.cpp11
-rw-r--r--benchmarks/bonnie++/files/patch-bonnie++.cpp14
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc.cpp20
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc_helper.cpp11
6 files changed, 55 insertions, 13 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index 92a5aa8c4c42..264b8c4a9a07 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bonnie++
-PORTVERSION= 1.97.3
+PORTVERSION= 1.98
CATEGORIES= benchmarks
MASTER_SITES= https://www.coker.com.au/bonnie++/
@@ -11,9 +11,9 @@ COMMENT= Performance Test of Filesystem I/O
LICENSE= GPLv2
-GNU_CONFIGURE= yes
-
USES= shebangfix tar:tgz
+
+GNU_CONFIGURE= yes
SHEBANG_FILES= bon_csv2txt.in
PORTDOCS= readme.html
diff --git a/benchmarks/bonnie++/distinfo b/benchmarks/bonnie++/distinfo
index c1df97421b62..28addae36e5a 100644
--- a/benchmarks/bonnie++/distinfo
+++ b/benchmarks/bonnie++/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1482419750
-SHA256 (bonnie++-1.97.3.tgz) = e27b386ae0dc054fa7b530aab6bdead7aea6337a864d1f982bc9ebacb320746e
-SIZE (bonnie++-1.97.3.tgz) = 100166
+TIMESTAMP = 1567440456
+SHA256 (bonnie++-1.98.tgz) = 6e0bcbc08b78856fd998dd7bcb352d4615a99c26c2dc83d5b8345b102bad0b04
+SIZE (bonnie++-1.98.tgz) = 100339
diff --git a/benchmarks/bonnie++/files/patch-bon_time.cpp b/benchmarks/bonnie++/files/patch-bon_time.cpp
new file mode 100644
index 000000000000..bdd4ca288bb3
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-bon_time.cpp
@@ -0,0 +1,11 @@
+--- bon_time.cpp.orig 2019-09-02 11:43:11 UTC
++++ bon_time.cpp
+@@ -146,7 +146,7 @@ int BonTimer::print_stat(tests_t test, i
+ }
+ else
+ {
+- fprintf(m_fp, " %5d", stat);
++ fprintf(m_fp, " %5f", stat);
+ }
+ }
+ else
diff --git a/benchmarks/bonnie++/files/patch-bonnie++.cpp b/benchmarks/bonnie++/files/patch-bonnie++.cpp
index 550f66b03411..12e01be32bfb 100644
--- a/benchmarks/bonnie++/files/patch-bonnie++.cpp
+++ b/benchmarks/bonnie++/files/patch-bonnie++.cpp
@@ -1,6 +1,6 @@
---- bonnie++.cpp.orig 2016-06-30 09:41:41.000000000 +0000
-+++ bonnie++.cpp 2016-10-18 19:52:40.381679719 +0000
-@@ -294,11 +294,7 @@
+--- bonnie++.cpp.orig 2019-09-02 18:10:39.852145000 +0200
++++ bonnie++.cpp 2019-09-02 18:12:18.027222000 +0200
+@@ -298,11 +298,7 @@
{
char *sbuf = _strdup(optarg);
char *size = strtok(sbuf, ":");
@@ -9,10 +9,10 @@
-#else
- file_size = size_from_str(size, "g");
-#endif
- size = strtok(NULL, "");
- if(size)
+ char * chunk_size = strtok(NULL, ":");
+ if(chunk_size)
{
-@@ -384,15 +380,6 @@
+@@ -398,15 +394,6 @@
if(file_size % 1024 > 512)
file_size = file_size + 1024 - (file_size % 1024);
}
@@ -28,7 +28,7 @@
globals.byte_io_size = min(file_size, globals.byte_io_size);
globals.byte_io_size = max(0, globals.byte_io_size);
-@@ -465,14 +452,6 @@
+@@ -479,14 +466,6 @@
&& (directory_max_size < directory_min_size || directory_max_size < 0
|| directory_min_size < 0) )
usage();
diff --git a/benchmarks/bonnie++/files/patch-getc_putc.cpp b/benchmarks/bonnie++/files/patch-getc_putc.cpp
new file mode 100644
index 000000000000..3ff9c2956453
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-getc_putc.cpp
@@ -0,0 +1,20 @@
+--- getc_putc.cpp.orig 2018-09-15 09:00:31.000000000 +0200
++++ getc_putc.cpp 2019-09-05 12:09:25.705704000 +0200
+@@ -206,7 +206,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc()", if( (c = getc(fp)) == EOF), res[Getc]);
++ TEST_FUNC_READ("getc()", int tmp = getc(fp); c = (char)tmp; if (tmp == EOF), res[Getc]);
+ if(fseek(fp, 0, SEEK_SET) != 0)
+ {
+ fprintf(stderr, "Can't seek.\n");
+@@ -221,7 +221,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc_unlocked()", if( (c = getc_unlocked(fp)) == EOF), res[GetcUnlocked]);
++ TEST_FUNC_READ("getc_unlocked()", int tmp = getc_unlocked(fp); c = (char)tmp; if (tmp == EOF), res[GetcUnlocked]);
+
+ if(!quiet)
+ printf("done\n");
diff --git a/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp b/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp
new file mode 100644
index 000000000000..a7edca3b1b6c
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-getc_putc_helper.cpp
@@ -0,0 +1,11 @@
+--- getc_putc_helper.cpp.orig 2009-07-03 04:26:05.000000000 +0200
++++ getc_putc_helper.cpp 2019-09-05 12:09:25.707876000 +0200
+@@ -45,7 +45,7 @@
+ return 1;
+ }
+ fflush(NULL);
+- TEST_FUNC_READ("getc() no thread", if( (c = getc(fp)) == EOF), res[1]);
++ TEST_FUNC_READ("getc() no thread", int tmp = getc(fp); c = (char)tmp; if (tmp == EOF), res[1]);
+ if(fseek(fp, 0, SEEK_SET) != 0)
+ {
+ fprintf(stderr, "Can't seek.\n");