aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-05-29 12:47:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-05-29 12:47:59 +0000
commitc0e21c588cf7f54a8aa22082ecb7dad177c6fa9f (patch)
tree934bc48a29a7e0d783483d1eb8aa8bcc34383321 /benchmarks
parentf175970fda2e14c177d39dbf99b89ecd88e09fd0 (diff)
downloadports-c0e21c588cf7f54a8aa22082ecb7dad177c6fa9f.tar.gz
ports-c0e21c588cf7f54a8aa22082ecb7dad177c6fa9f.zip
- Drop empty `do-fetch' target: this is the default when both
DISTFILES and PATCHFILES are empty - Define LICENSE (BSD2CLAUSE) - Convert 42-line pkg-descr into README file, fix a typo and give it better formatting
Notes
Notes: svn path=/head/; revision=502956
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/raidtest/Makefile11
-rw-r--r--benchmarks/raidtest/files/README42
-rw-r--r--benchmarks/raidtest/pkg-descr43
3 files changed, 54 insertions, 42 deletions
diff --git a/benchmarks/raidtest/Makefile b/benchmarks/raidtest/Makefile
index 0928246a0411..e5df5c8fd5ad 100644
--- a/benchmarks/raidtest/Makefile
+++ b/benchmarks/raidtest/Makefile
@@ -10,14 +10,21 @@ DISTFILES= # none
MAINTAINER= pjd@FreeBSD.org
COMMENT= Test performance of storage devices
+LICENSE= BSD2CLAUSE
+
NO_WRKSUBDIR= yes
USES= uidfix
PLIST_FILES= bin/raidtest
+PORTDOCS= README
-do-fetch:
+OPTIONS_DEFINE= DOCS
do-extract:
- ${MKDIR} ${WRKSRC}
+ @${MKDIR} ${WRKSRC}
${LN} -sf ${FILESDIR}/${PORTNAME}.c ${FILESDIR}/Makefile ${WRKSRC}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/benchmarks/raidtest/files/README b/benchmarks/raidtest/files/README
new file mode 100644
index 000000000000..e7419d934a5b
--- /dev/null
+++ b/benchmarks/raidtest/files/README
@@ -0,0 +1,42 @@
+This utility can be used to test performance of storage devices.
+First, one need to generate file with I/O operations:
+
+ # set mediasize=`diskinfo /dev/<device> | awk '{print $3}'`
+ # set sectorsize=`diskinfo /dev/<device> | awk '{print $2}'`
+ # raidtest genfile -s $mediasize -S $sectorsize -n 50000
+
+It will generate test which contains 50000 I/O requests with random
+size and random offset. Size is a multiple of sectorsize, but less
+than or equal to 128kB (maximum size of I/O request). I/O request
+type (READ or WRITE) is random as well.
+
+All test data are stored in 'raidtest.data' file in current working
+directory. To run test, one should type:
+
+ # raidtest test -d /dev/<device> -n 10
+
+This command will read test data from 'raidtest.data' file, run 10
+processes which will be used to send requests to the given device
+in parallel. When test is finished you will see statistics:
+
+ Bytes per second: <x>
+ Requests per second: <y>
+
+If you want to compare performance of two storage devices, use the
+same data file!
+
+usage: raidtest genfile [-frw] <-s mediasize> [-S sectorsize] <-n nrequests> [file]
+ raidtest test [-Rrw] <-d device> [-n processes] [file]
+
+where:
+ -d device path to tested device
+ -f if raidtest.data file or specified file already exists,
+ remove it and create new one
+ -n nrequests number of requests to generate
+ -n processes number of processes to run
+ -r generate/run only READ requests
+ -R generate random data for write requests
+ -s size of destination device
+ -S sector size of destination device
+ -w generate/run only WRITE requests
+ file path to the data file instead of default 'raidtest.data'
diff --git a/benchmarks/raidtest/pkg-descr b/benchmarks/raidtest/pkg-descr
index 600feaa6953c..4e8b202efaeb 100644
--- a/benchmarks/raidtest/pkg-descr
+++ b/benchmarks/raidtest/pkg-descr
@@ -1,42 +1,5 @@
This utility can be used to test performance of storage devices.
-First, one need to generate file with I/O operations:
- # set mediasize=`diskinfo /dev/<device> | awk '{print $3}'`
- # set sectorsize=`diskinfo /dev/<device> | awk '{print $2}'`
- # raidtest genfile -s $mediasize -S $sectorsize -n 50000
-
-It will generate test which contains 50000 I/O requests with random
-size and random offset. Size is a multiple of sectorsize, but less than or
-equal to 128kB (maxium size of I/O request). I/O request type (READ or WRITE)
-is random as well.
-All test data are stored in 'raidtest.data' file in current working directory.
-
-To run test, one should type:
-
- # raidtest test -d /dev/<device> -n 10
-
-This command will read test data from 'raidtest.data' file, run 10 processes
-which will be used to send requests to the given device in parallel.
-When test is finished you will see statistics:
-
- Bytes per second: <x>
- Requests per second: <y>
-
-If you compare performance of two storage devices, use the same data file!
-
-
-usage: raidtest genfile [-frw] <-s mediasize> [-S sectorsize] <-n nrequests> [file]
- raidtest test [-Rrw] <-d device> [-n processes] [file]
-
-where:
- -d device path to tested device
- -f if raidtest.data file or specified file already exists,
- remove it and create new one
- -n nrequests number of requests to generate
- -n processes number of processes to run
- -r generate/run only READ requests
- -R generate random data for write requests
- -s size of destination device
- -S sector size of destination device
- -w generate/run only WRITE requests
- file path to the data file instead of default 'raidtest.data'
+It works by generating a test file which contains I/O requests with
+random size and random offset. It then spawns parallel processes
+which send requests to the given device based on the test file data.