aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-15 07:05:53 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-15 07:05:53 +0000
commit4612d2325f9d1bd42754ae93497d67ef1a3ed400 (patch)
tree9272579d43cb9440bfddbaee7da6e17d0445b96b /benchmarks
parenta15e60cfd1b65b694d284d53fbb173a737536018 (diff)
downloadports-4612d2325f9d1bd42754ae93497d67ef1a3ed400.tar.gz
ports-4612d2325f9d1bd42754ae93497d67ef1a3ed400.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/lzbench/Makefile32
-rw-r--r--benchmarks/lzbench/distinfo3
-rw-r--r--benchmarks/lzbench/pkg-descr10
4 files changed, 46 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 9eae50b082b9..49339f659e00 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -38,6 +38,7 @@
SUBDIR += iperf3
SUBDIR += libmicro
SUBDIR += lmbench
+ SUBDIR += lzbench
SUBDIR += mdtest
SUBDIR += nbench
SUBDIR += netio
diff --git a/benchmarks/lzbench/Makefile b/benchmarks/lzbench/Makefile
new file mode 100644
index 000000000000..bfbea4051f9d
--- /dev/null
+++ b/benchmarks/lzbench/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lzbench
+PORTVERSION= 1.7.3
+DISTVERSIONPREFIX= v
+CATEGORIES= benchmarks
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= In-memory benchmark of open-source LZ77/LZSS/LZMA compressors
+
+USES= compiler:c11 gmake
+USE_GITHUB= yes
+GH_ACCOUNT= inikep
+
+PLIST_FILES= bin/lzbench
+PORTDOCS= NEWS
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e '/PROGOS/s,Linux,${OPSYS},' \
+ ${WRKSRC}/_lzbench/lzbench.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lzbench ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/benchmarks/lzbench/distinfo b/benchmarks/lzbench/distinfo
new file mode 100644
index 000000000000..6e3d08d9c9de
--- /dev/null
+++ b/benchmarks/lzbench/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515146810
+SHA256 (inikep-lzbench-v1.7.3_GH0.tar.gz) = 71308d03b3a1e00ac4852bc8ca0ec45540144b1de232db3dd4880cecd1b07e36
+SIZE (inikep-lzbench-v1.7.3_GH0.tar.gz) = 2365027
diff --git a/benchmarks/lzbench/pkg-descr b/benchmarks/lzbench/pkg-descr
new file mode 100644
index 000000000000..21fbc88eb3e3
--- /dev/null
+++ b/benchmarks/lzbench/pkg-descr
@@ -0,0 +1,10 @@
+lzbench is an in-memory benchmark of open-source LZ77/LZSS/LZMA compressors.
+It joins all compressors into a single executable. At the beginning, an
+input file is read to memory. Then all compressors are used to compress
+and decompress the file and decompressed file is verified.
+
+This approach has a big advantage of using the same compiler with the same
+optimizations for all compressors. The disadvantage is that it requires
+source code of each compressor (therefore Slug or lzturbo are not included).
+
+WWW: https://github.com/inikep/lzbench