aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-11-10 02:56:41 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-11-10 02:56:41 +0000
commita8997a6984bd9c4f2e35c6af4801b6d58f41ee19 (patch)
tree82c198b5382eb7be659518989e4d7312ecb2609c /benchmarks
parent0f20967179622c135807c2a3248accb2c77506a8 (diff)
downloadports-a8997a6984bd9c4f2e35c6af4801b6d58f41ee19.tar.gz
ports-a8997a6984bd9c4f2e35c6af4801b6d58f41ee19.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/stress-ng/Makefile2
-rw-r--r--benchmarks/stress-ng/distinfo4
-rw-r--r--benchmarks/stress-ng/files/patch-stress-cpu.c28
3 files changed, 3 insertions, 31 deletions
diff --git a/benchmarks/stress-ng/Makefile b/benchmarks/stress-ng/Makefile
index 3c6c9b170afd..789748b80dcc 100644
--- a/benchmarks/stress-ng/Makefile
+++ b/benchmarks/stress-ng/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= stress-ng
-PORTVERSION= 0.04.20
+PORTVERSION= 0.04.21
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
diff --git a/benchmarks/stress-ng/distinfo b/benchmarks/stress-ng/distinfo
index 4f1a98de95f2..ee1e07f651b5 100644
--- a/benchmarks/stress-ng/distinfo
+++ b/benchmarks/stress-ng/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stress-ng-0.04.20.tar.gz) = 5b00c23325e46236466e598a977c8ebcd4f786cc0c2e15118004a0462bb6f47f
-SIZE (stress-ng-0.04.20.tar.gz) = 236074
+SHA256 (stress-ng-0.04.21.tar.gz) = 1c02e5752349cbf08f5828046786481f8e43180a8e9c3cf8b1f4f41606436004
+SIZE (stress-ng-0.04.21.tar.gz) = 243140
diff --git a/benchmarks/stress-ng/files/patch-stress-cpu.c b/benchmarks/stress-ng/files/patch-stress-cpu.c
index 9d0f5e631998..c25e65e2fe80 100644
--- a/benchmarks/stress-ng/files/patch-stress-cpu.c
+++ b/benchmarks/stress-ng/files/patch-stress-cpu.c
@@ -8,31 +8,3 @@
#endif
/*
-@@ -866,6 +866,7 @@ stress_cpu_fp(_Decimal128, decimal128, s
- /* Append floating point literal specifier to literal value */
- #define FP(val, ltype) val ## ltype
-
-+#if defined(__STDC_IEC_559_COMPLEX__)
- /*
- * Generic complex stressor macro
- */
-@@ -891,6 +892,7 @@ static void HOT OPTIMIZE3 stress_cpu_ ##
- stress_cpu_complex(complex float, f, complex_float, csinf, ccosf)
- stress_cpu_complex(complex double, , complex_double, csin, ccos)
- stress_cpu_complex(complex long double, l, complex_long_double, csinl, ccosl)
-+#endif /* __STDC_IEC_559_COMPLEX__ */
-
- #define int_float_ops(_ftype, flt_a, flt_b, flt_c, flt_d, \
- _sin, _cos, int_a, int_b, _c1, _c2, _c3) \
-@@ -2058,9 +2060,11 @@ static stress_cpu_stressor_info_t cpu_me
- { "ackermann", stress_cpu_ackermann },
- { "bitops", stress_cpu_bitops },
- { "callfunc", stress_cpu_callfunc },
-+#if defined(__STDC_IEC_559_COMPLEX__)
- { "cdouble", stress_cpu_complex_double },
- { "cfloat", stress_cpu_complex_float },
- { "clongdouble", stress_cpu_complex_long_double },
-+#endif /* __STDC_IEC_559_COMPLEX__ */
- { "correlate", stress_cpu_correlate },
- { "crc16", stress_cpu_crc16 },
- #if defined(STRESS_FLOAT_DECIMAL)