aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-07-05 11:53:08 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-07-05 11:53:08 +0000
commit958b931ab82951444e77496917a4b432a23d58f8 (patch)
treea44810a1ed33d76e1368ba7e629aebe7634843e1 /benchmarks
parent83743a5de0ef426165d3c450251187f7903ccef8 (diff)
downloadports-958b931ab82951444e77496917a4b432a23d58f8.tar.gz
ports-958b931ab82951444e77496917a4b432a23d58f8.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/flowgrind/Makefile3
-rw-r--r--benchmarks/flowgrind/files/patch-flowgrind29
2 files changed, 31 insertions, 1 deletions
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index 46f87871d13d..7f46a8d9bfd6 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flowgrind
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= https://launchpad.net/flowgrind/trunk/${PORTNAME}-0.6/+download/
@@ -16,6 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.so:${PORTSDIR}/net/libpcap
USE_BZIP2= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-debug
FETCH_ARGS= -pRr
MAN1= flowgrind-stop.1 \
diff --git a/benchmarks/flowgrind/files/patch-flowgrind b/benchmarks/flowgrind/files/patch-flowgrind
new file mode 100644
index 000000000000..89074e2d4d35
--- /dev/null
+++ b/benchmarks/flowgrind/files/patch-flowgrind
@@ -0,0 +1,29 @@
+--- src/flowgrind.c
++++ src/flowgrind.c
+@@ -1872,7 +1872,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
+
+ if (extra_rpc) {
+ /* Now it's getting tricky... */
+- /* 1st case: IPv6 with port, e.g. "[a:b::c]a:5999" */
++ /* 1st case: IPv6 with port, e.g. "[a:b::c]:5999" */
+ if ((sepptr = strchr(rpc_address, ']'))) {
+ is_ipv6 = 1;
+ *sepptr = '\0';
+@@ -1884,7 +1884,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
+ port = atoi(sepptr);
+ } else if ((sepptr = strchr(rpc_address, ':'))) {
+ /* 2nd case: IPv6 without port, e.g. "a:b::c" */
+- if (strchr(sepptr, ':')) {
++ if (strchr(sepptr+1, ':')) {
+ is_ipv6 = 1;
+ } else {
+ /* 3rd case: IPv4 or name with port 1.2.3.4:5999*/
+@@ -1910,7 +1910,7 @@ static void parse_flow_option(int ch, char* optarg, int current_flow_ids[]) {
+ fprintf(stderr, "No test host given in argument\n");
+ usage();
+ }
+- if (is_ipv6)
++ if (is_ipv6)
+ sprintf(url, "http://[%s]:%d/RPC2", rpc_address, port);
+ else
+ sprintf(url, "http://%s:%d/RPC2", rpc_address, port);