aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:53:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:53:05 +0000
commitbd1e9899232dd980bc678e27337eab8aec04eecb (patch)
tree3c28b4cd8940a37151c99f008cce76032cccc8f4 /benchmarks
parent48213b26e0883c379fade6e570b00e8a23dd2fa1 (diff)
downloadports-bd1e9899232dd980bc678e27337eab8aec04eecb.tar.gz
ports-bd1e9899232dd980bc678e27337eab8aec04eecb.zip
Notes
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/pybench/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index 0dd4fa9b970e..9a74e7526c53 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -5,37 +5,31 @@ PORTNAME= pybench
PORTVERSION= 2.0
CATEGORIES= benchmarks python
MASTER_SITES= http://downloads.egenix.com/python/
+EXTRACT_SUFX= .zip
MAINTAINER= sylvio@FreeBSD.org
COMMENT= An extensible benchmark suite for Python
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_ZIP= yes
USE_PYTHON= yes
PORTDOCS= README
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
-
do-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
do-install:
- @${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${TAR} --exclude README -c -f - .) \
- | (cd ${DATADIR} && ${TAR} --unlink -x -f -)
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${TAR} --exclude README -C ${WRKSRC} -c -f - . \
+ | ${TAR} --unlink -x -C ${STAGEDIR}${DATADIR} -f -
@${PRINTF} '#!/bin/sh\n${PYTHON_CMD} ${DATADIR}/pybench.py "$$@"\n' \
> ${WRKDIR}/pybench.sh
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- @${INSTALL_SCRIPT} ${WRKDIR}/pybench.sh ${PREFIX}/bin/pybench
+ @${INSTALL_SCRIPT} ${WRKDIR}/pybench.sh ${STAGEDIR}${PREFIX}/bin/pybench
.include <bsd.port.mk>