aboutsummaryrefslogtreecommitdiff
path: root/biology/babel/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-03-31 15:51:15 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-03-31 15:51:15 +0000
commit177bea6922e18eef84169fcef6c964f3de2fd7ab (patch)
tree6b721c5ef8b1cd8f2cf838666743fc39f456579f /biology/babel/Makefile
parentcbcd4ad0158a6181e9ca24011601fb6433ae2850 (diff)
downloadports-177bea6922e18eef84169fcef6c964f3de2fd7ab.tar.gz
ports-177bea6922e18eef84169fcef6c964f3de2fd7ab.zip
Notes
Diffstat (limited to 'biology/babel/Makefile')
-rw-r--r--biology/babel/Makefile24
1 files changed, 18 insertions, 6 deletions
diff --git a/biology/babel/Makefile b/biology/babel/Makefile
index 52bdda2782aa..14721030a0b2 100644
--- a/biology/babel/Makefile
+++ b/biology/babel/Makefile
@@ -1,19 +1,31 @@
-# New ports collection Makefile for: babel
-# Date created: Dec 4 1997
-# Whom: frankch@waru.life.nthu.edu.tw
+# New ports collection Makefile for: babel
+# Date created: Dec 4 1997
+# Whom: frankch@waru.life.nthu.edu.tw
#
# $FreeBSD$
#
PORTNAME= babel
PORTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= biology
-MASTER_SITES= ftp://ccl.osc.edu/pub/chemistry/software/MAC/babel/
+MASTER_SITES= http://smog.com/chem/babel/files/ \
+ http://www.ccl.net/cca/software/UNIX/babel/ \
+ ftp://ccl.osc.edu/pub/chemistry/software/UNIX/babel/
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-post-install:
- @ ${CAT} ${PKGMESSAGE} | ${SED} -e 's:/usr/local:${PREFIX}:'
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/babel ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/babel
+ ${INSTALL_DATA} ${WRKSRC}/*.lis ${PREFIX}/share/babel
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/babel
+ ${INSTALL_DATA} ${WRKSRC}/README.1ST ${PREFIX}/share/doc/babel
+.endif
+ @${SED} -e 's:/usr/local:${PREFIX}:' ${PKGMESSAGE}
.include <bsd.port.mk>