aboutsummaryrefslogtreecommitdiff
path: root/biology/belvu
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:24:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:24:57 +0000
commitbfe1c1f2602aa83afd3a37e632891b90666d73c7 (patch)
tree5dd913333d4424446ef1a07d3339a8ba436cd55c /biology/belvu
parent045fee6c94449a637a67a4f0afb35488b630b397 (diff)
downloadports-bfe1c1f2602aa83afd3a37e632891b90666d73c7.tar.gz
ports-bfe1c1f2602aa83afd3a37e632891b90666d73c7.zip
Notes
Diffstat (limited to 'biology/belvu')
-rw-r--r--biology/belvu/Makefile38
-rw-r--r--biology/belvu/distinfo3
-rw-r--r--biology/belvu/pkg-descr12
3 files changed, 53 insertions, 0 deletions
diff --git a/biology/belvu/Makefile b/biology/belvu/Makefile
new file mode 100644
index 000000000000..bb24d2f600af
--- /dev/null
+++ b/biology/belvu/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# New ports collection makefile for: belvu
+# Date created: 11 Jan 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= belvu
+PORTVERSION= 2.29
+CATEGORIES= biology
+MASTER_SITES= ftp://ftp.cgb.ki.se/pub/prog/belvu/
+DISTNAME= ${PORTNAME}.LIN_${PORTVERSION}
+EXTRACT_SUFX= #
+EXTRACT_ONLY= #
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A viewer for multiple sequence alignments
+
+USE_LINUX= yes
+
+NO_BUILD= yes
+PLIST_FILES= bin/${PORTNAME} bin/${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+IGNORE= there are also executables for Alpha and Sparc \
+ but they are for OSF and Solaris ... do they \
+ run on FreeBSD-Sparc and FreeBSD-alpha?
+.endif
+
+do-install:
+ ${BRANDELF} -t Linux ${DISTDIR}/${DISTNAME}
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DISTNAME} ${PREFIX}/bin
+ ( cd ${PREFIX}/bin && ${LN} -s ${DISTNAME} ${PORTNAME} )
+
+.include <bsd.port.post.mk>
diff --git a/biology/belvu/distinfo b/biology/belvu/distinfo
new file mode 100644
index 000000000000..3170fd60e82c
--- /dev/null
+++ b/biology/belvu/distinfo
@@ -0,0 +1,3 @@
+MD5 (belvu.LIN_2.29) = 68e59a37a6a632f24221b96ea65bf006
+SHA256 (belvu.LIN_2.29) = 45a7da0eebc23a9352241cf1b078c7f74bc938284dc2308935fcaff78e8b1112
+SIZE (belvu.LIN_2.29) = 6181981
diff --git a/biology/belvu/pkg-descr b/biology/belvu/pkg-descr
new file mode 100644
index 000000000000..9f3e292c7108
--- /dev/null
+++ b/biology/belvu/pkg-descr
@@ -0,0 +1,12 @@
+Belvu is an X-windows viewer for multiple sequence alignments. One of the main
+advantages of Belvu is that it has an extensive set of modes to color the
+residues. There are several ways to color them by conservation and by residue
+type (user-configurable). Other useful features are fetching of the Swissprot
+(or PIR) entries by double clicking and easy tracking of the position in the
+alignment.
+
+Belvu further supports some simple editing commands for rows and columns, but
+is not intended as a full editor. For actually editing the alignment, use your
+favorite alignment editor or Emacs.
+
+WWW: http://www.cgb.ki.se/cgb/groups/sonnhammer/Belvu.html