aboutsummaryrefslogtreecommitdiff
path: root/biology/consed/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:00:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-24 07:00:37 +0000
commit69ef603a618688f044050396aace9411be47fe96 (patch)
treeee01c07fc9140f30a31f951472ea74d9b05ea376 /biology/consed/Makefile
parent94717e523429218114c4c7cdba39267dd31904b1 (diff)
downloadports-69ef603a618688f044050396aace9411be47fe96.tar.gz
ports-69ef603a618688f044050396aace9411be47fe96.zip
Notes
Diffstat (limited to 'biology/consed/Makefile')
-rw-r--r--biology/consed/Makefile104
1 files changed, 104 insertions, 0 deletions
diff --git a/biology/consed/Makefile b/biology/consed/Makefile
new file mode 100644
index 000000000000..15700c79f7bf
--- /dev/null
+++ b/biology/consed/Makefile
@@ -0,0 +1,104 @@
+# New ports collection makefile for: phred
+# Date created: 8 July 2005
+# Whom: Motomichi Matsuzaki <mzaki@biol.s.u-tokyo.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= consed
+PORTVERSION= 16.0
+CATEGORIES= biology
+MASTER_SITES= http://www.phrap.org/consed/distributions/${PORTVERSION}/
+DISTNAME= ${PORTNAME}_linux
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= mzaki@biol.s.u-tokyo.ac.jp
+COMMENT= A graphical tool for editing Phrap assemblies
+
+RUN_DEPENDS= phred:${PORTSDIR}/biology/phred \
+ phrap:${PORTSDIR}/biology/phrap \
+ phd2fasta:${PORTSDIR}/biology/phd2fasta
+
+USE_PERL5= yes
+USE_LINUX= yes
+USE_XLIB= yes
+ONLY_FOR_ARCHS= i386 amd64
+
+RESTRICTED= Redistribution is not permitted in any form. You must request access permission via e-mail to get the tarball. Free for academic use.
+
+NO_WRKSUBDIR= yes
+
+BUILD_WRKSRC= ${WRKSRC}/misc/mktrace
+ALL_TARGET= mktrace
+
+BINARIES= consed mktrace sffinfo sff2scf
+CONTRIBS= ace2OligosWithComments.perl ace2fof \
+ aceContigs2Phds.perl acestatus.pl export_cons \
+ mergeAces.perl recover_consensus_tags revert_fof
+SCRIPTS= ace2Fasta.perl ace2Oligos.perl addReads2Consed.perl \
+ amplifyTranscripts.perl catPhdFiles.perl \
+ countEditedBases.perl determineReadTypes.perl fasta2Phd.perl \
+ findSequenceMatchesForConsed.perl lib2Phd.perl \
+ orderPrimerPairs.perl phd2Ace.perl phredPhrap removeReads \
+ revertToUneditedRead tagRepeats.perl transferConsensusTags.perl
+.for f in ${BINARIES} ${CONTRIBS} ${SCRIPTS}
+PLIST_FILES+= bin/${f}
+.endfor
+
+DATADIR= ${PREFIX}/lib/screenLibs
+DATAFILES= primerCloneScreen.seq primerSubcloneScreen.seq \
+ repeats.fasta singleVectorForRestrictionDigest.fasta
+NULLFILES= vector.seq
+.for f in ${DATAFILES} ${NULLFILES}
+PORTDATA+= ${f}.dist
+.endfor
+PORTDOCS= README.txt
+
+.if defined(WITH_EXAMPLES)
+EXAMPLES= standard autofinish assembly_view polyphred
+PLIST= ${PKGDIR}/pkg-plist.examples
+.endif
+
+post-build:
+ (cd ${WRKSRC}/misc/454; ${CC} ${CFLAGS} sffinfo.c -o sffinfo)
+ (cd ${WRKSRC}/misc/454; ${CC} ${CFLAGS} sff2scf.c -o sff2scf)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/consed_linux2.4 ${PREFIX}/bin/consed
+ @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/mktrace ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/misc/454/sffinfo ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/misc/454/sff2scf ${PREFIX}/bin/
+.for f in ${BINARIES}
+ @${CHMOD} a-r ${PREFIX}/bin/${f}
+.endfor
+.for f in ${CONTRIBS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/contributions/${f} ${PREFIX}/bin/
+.endfor
+.for f in ${SCRIPTS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${f} ${PREFIX}/bin/
+.endfor
+ @${MKDIR} ${DATADIR}
+.for f in ${DATAFILES}
+ @${INSTALL_DATA} ${WRKSRC}/misc/${f} ${DATADIR}/${f}.dist
+.endfor
+.for f in ${NULLFILES}
+ @${INSTALL_DATA} /dev/null ${DATADIR}/${f}.dist
+.endfor
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for dir in ${EXAMPLES}
+ @${CP} -R ${WRKSRC}/${dir} ${EXAMPLESDIR}
+.endfor
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(WITH_EXAMPLES)
+ @${ECHO_CMD} "Examples were not installed. You can define WITH_EXAMPLES=yes to install them."
+.endif
+ @${ECHO_CMD} "You must set the CONSED_HOME environment variable to '${PREFIX}'"
+
+.include <bsd.port.mk>