aboutsummaryrefslogtreecommitdiff
path: root/biology/deft/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-29 08:15:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-29 08:15:13 +0000
commitfacc5fd9197a0d36e9ad4ef0fa0747ff1a5f741b (patch)
tree77de2e29029bd574dc5c174bee7e7f87ff175e2b /biology/deft/Makefile
parent8c85c0fa9a9e4b9017c8c6ed17c1b10f9ab04d06 (diff)
downloadports-facc5fd9197a0d36e9ad4ef0fa0747ff1a5f741b.tar.gz
ports-facc5fd9197a0d36e9ad4ef0fa0747ff1a5f741b.zip
Notes
Diffstat (limited to 'biology/deft/Makefile')
-rw-r--r--biology/deft/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/biology/deft/Makefile b/biology/deft/Makefile
index 7e24f917645b..cda1ba957472 100644
--- a/biology/deft/Makefile
+++ b/biology/deft/Makefile
@@ -7,9 +7,9 @@
PORTNAME= deft
PORTVERSION= 2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
-MASTER_SITES= ftp://theory.chem.uottawa.ca/pub/
+MASTER_SITES= http://www.dq.ufscar.br/download/chem/dft/
DISTNAME= DeFT_${PORTVERSION}
EXTRACT_SUFX= .tar.Z
@@ -23,13 +23,27 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/source
# Using g77 is troublesome, then it is better to use f2c/cc.
BUILD_DEPENDS= ftn77:${PORTSDIR}/lang/f77
.endif
+.if defined(USEMPICH) && ${USEMPICH} == yes
+BUILD_DEPENDS+= mpif77:${PORTSDIR}/net/mpich
+FFLAGS+= -I/usr/local/mpich/include
+FC= /usr/local/mpich/bin/mpif77
+LFLAGS+= -L/usr/local/mpich/lib -lmpich
+.endif
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g"\
${WRKDIR}/${DISTNAME}/examples/DeFT
+.if !defined(USEMPICH)
+ @echo "******************************"
+ @echo "If you want to use MPI library, set 'USEMPICH=yes'."
+ @echo "******************************"
+.endif
post-configure:
${CP} ${FILESDIR}/Makefile.deft ${WRKSRC}/Makefile
+.if defined(USEMPICH) && ${USEMPICH} == yes
+ ${MV} ${WRKSRC}/mpi.f ${WRKSRC}/mpi.f.notuse
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/DeFT.exec ${PREFIX}/bin/