aboutsummaryrefslogtreecommitdiff
path: root/biology/dotter
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:35:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:35:24 +0000
commit1b3445b6845f25a3702f057a83a56b2721d27241 (patch)
tree6d07aaf76fb8a8a47048904b269be292d55ea927 /biology/dotter
parent69b5248cc2b8c56e5d0f57335de060b95d241fa5 (diff)
downloadports-1b3445b6845f25a3702f057a83a56b2721d27241.tar.gz
ports-1b3445b6845f25a3702f057a83a56b2721d27241.zip
Notes
Diffstat (limited to 'biology/dotter')
-rw-r--r--biology/dotter/Makefile40
-rw-r--r--biology/dotter/distinfo3
-rw-r--r--biology/dotter/pkg-descr19
3 files changed, 62 insertions, 0 deletions
diff --git a/biology/dotter/Makefile b/biology/dotter/Makefile
new file mode 100644
index 000000000000..239a4c5811a9
--- /dev/null
+++ b/biology/dotter/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# New ports collection makefile for: dotter
+# Date created: 11 Jan 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dotter
+PORTVERSION= 20021204 # last modified date in FTP server
+CATEGORIES= biology
+MASTER_SITES= ftp://ftp.cgb.ki.se/pub/esr/dotter/
+DISTNAME= ${PORTNAME}.LIN
+EXTRACT_SUFX= #
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= #
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A viewer for multiple sequence alignments
+
+USE_LINUX= yes
+
+NO_BUILD= yes
+PLIST_FILES= bin/${PORTNAME} bin/${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+IGNORE= there are also executables for Alpha and Sparc \
+ but they are for OSF and Solaris ... do they \
+ run on FreeBSD-Sparc and FreeBSD-alpha?
+.endif
+
+do-install:
+ ${BRANDELF} -t Linux ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ ${PREFIX}/bin
+ ( cd ${PREFIX}/bin && ${LN} -s ${DISTNAME} ${PORTNAME} )
+
+.include <bsd.port.post.mk>
diff --git a/biology/dotter/distinfo b/biology/dotter/distinfo
new file mode 100644
index 000000000000..a4a8cd00d4e7
--- /dev/null
+++ b/biology/dotter/distinfo
@@ -0,0 +1,3 @@
+MD5 (dotter-20021204/dotter.LIN) = a308eb0b710b5e3e741ee09bd4b0982e
+SHA256 (dotter-20021204/dotter.LIN) = c66bae7704b2fa305f848451cf35b7a0738a3fd57468da1393684328f111cd75
+SIZE (dotter-20021204/dotter.LIN) = 4804333
diff --git a/biology/dotter/pkg-descr b/biology/dotter/pkg-descr
new file mode 100644
index 000000000000..1f04ae8b9118
--- /dev/null
+++ b/biology/dotter/pkg-descr
@@ -0,0 +1,19 @@
+Dotter is a graphical dotplot program for detailed comparison of two sequences.
+Here, every residue in one sequence is compared to every residue in the other
+sequence. The first sequence runs along the x-axis and the second sequence
+along the y-axis. In regions where the two sequences are similar to each other,
+a row of high scores will run diagonally across the dot matrix. If you're
+comparing a sequence against itself to find internal repeats, you'll notice
+that the main diagonal scores maximally, since it's the 100% perfect
+self-match.
+
+To make the score matrix more intelligible, the pairwise scores are averaged
+over a sliding window which runs diagonally. The averaged score matrix forms a
+three-dimensional landscape, with the two sequences in two dimensions and the
+height of the peaks in the third. This landscape is projected onto two
+dimensions by aid of greyscales - the darker grey of a peak, the higher it is.
+
+Dotter provides a tool to explore the visual appearance of this landscape, as
+well as a tool to examine the sequence alignment it represents.
+
+WWW: http://www.cgb.ki.se/cgb/groups/sonnhammer/Dotter.html