aboutsummaryrefslogtreecommitdiff
path: root/biology/emboss/Makefile
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-01-18 14:04:03 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-01-18 14:04:03 +0000
commit443693b9ae247d0492e29c40a630c3234ca0fee5 (patch)
treedbf38a5cf8558a46946607790c1bf2abfa9d73b1 /biology/emboss/Makefile
parent39ba379e3b254d38393ec8ba442f6a9a0a184f0c (diff)
- Update to version 2.2.0
- Update included EMBASSY package EMNU - Fix a long-standing bug in Makefile that would preclude PKGMESSAGE from being generated properly - Consider this an interim update merely to track the latest version - more work is required to activate the newly included "Jemboss" Java GUI interface
Notes
Notes: svn path=/head/; revision=53296
Diffstat (limited to 'biology/emboss/Makefile')
-rw-r--r--biology/emboss/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/biology/emboss/Makefile b/biology/emboss/Makefile
index 52c50aea85e5..48db1adca305 100644
--- a/biology/emboss/Makefile
+++ b/biology/emboss/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= emboss
-PORTVERSION= 2.0.1
+PORTVERSION= 2.2.0
CATEGORIES= biology
MASTER_SITES= ftp://ftp.uk.embnet.org/pub/EMBOSS/ \
- ftp://ftp.no.embnet.org/pub/EMBOSS/ \
ftp://ftp.es.embnet.org/pub/software/emboss/EMBOSS/ \
ftp://ftp.ebi.ac.uk/pub/software/unix/EMBOSS/
DISTFILES= ${PORTNAME:U}-${PORTVERSION}${EXTRACT_SUFX}
@@ -21,7 +20,7 @@ MAINTAINER= wjv@FreeBSD.org
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_XLIB= yes
USE_MOTIF= yes
@@ -38,7 +37,7 @@ SCRIPTS_ENV+= WRKDIRPREFIX="${WRKDIRPREFIX}" \
WRKSRC= ${WRKDIR}/${PORTNAME:U}-${PORTVERSION}
EMBASSY_WRKDIR= ${WRKSRC}/EMBASSY
-EMNU_VERSION= 1.0.4
+EMNU_VERSION= 1.0.5
HMMER_VERSION= 2.1.1
MEME_VERSION= 2.3.1
MSE_VERSION= 0.0.4
@@ -111,9 +110,9 @@ post-install:
${CONFIG_FILE} > ${PREFIX}/etc/emboss.default.sample && \
${CHOWN} ${SHAREOWN}:${SHAREGRP} \
${PREFIX}/etc/emboss.default.sample
-.if !defined(BATCH)
@ ${PERL} -pe 's#%%PREFIX%%#${PREFIX}#' \
pkg-message > ${PKGMESSAGE}
+.if !defined(BATCH)
@ ${CAT} ${PKGMESSAGE}
.endif