aboutsummaryrefslogtreecommitdiff
path: root/biology/fasta/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-02-11 16:24:18 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-02-11 16:24:18 +0000
commitc82fc943113baf5de2e9b2282c7f015ba8965de9 (patch)
treee1341803fd3045f53f3dd1852e88928fc6e80c85 /biology/fasta/Makefile
parentb03bca912cc7f9544e8da92771777aaa85bcc9c4 (diff)
downloadports-c82fc943113baf5de2e9b2282c7f015ba8965de9.tar.gz
ports-c82fc943113baf5de2e9b2282c7f015ba8965de9.zip
Notes
Diffstat (limited to 'biology/fasta/Makefile')
-rw-r--r--biology/fasta/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/biology/fasta/Makefile b/biology/fasta/Makefile
new file mode 100644
index 000000000000..a5cff36068c4
--- /dev/null
+++ b/biology/fasta/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: fasta
+# Date created: 29 January 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fasta
+PORTVERSION= 20.u66
+CATEGORIES= biology
+MASTER_SITES= http://ftp.virginia.edu/pub/fasta/
+DISTNAME= fasta${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .shar.Z
+
+MAINTAINER= johann@egenetics.com
+
+NO_CDROM= May not be sold or incorporated into a commercial product
+WRKSRC= ${WRKDIR}/fasta
+PKGMESSAGE= ${WRKDIR}/pkg-message
+FASTA_DOCDIR= ${PREFIX}/share/doc/fasta
+FASTA_DOCS= COPYRIGHT README.versions fasta20.doc fasta20.me format.doc \
+ readme.*
+
+MAN1= align.1 fasta.1 lalign.1 prdf.1 prss.1 randseq.1 ssearch.1
+MLINKS= fasta.1 tfasta.1 fasta.1 lfasta.1 fasta.1 plfasta.1 \
+ fasta.1 fastx.1 fasta.1 tfastx.1 \
+ align.1 align0.1 lalign.1 plalign.1
+
+do-extract:
+ @ ${RM} -rf ${WRKDIR}
+ @ ${MKDIR} ${WRKSRC}
+ @ for file in ${EXTRACT_ONLY}; do \
+ cd ${WRKSRC} && (${GZCAT} ${DISTDIR}/$${file} | ${SH} >/dev/null); \
+ done
+
+post-install:
+.for manpage in ${MAN1}
+ @ ${INSTALL_MAN} ${WRKSRC}/${manpage} ${MAN1PREFIX}/man/man1/
+.endfor
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${FASTA_DOCDIR}
+.for docfile in ${FASTA_DOCS}
+ @ ${INSTALL_MAN} ${WRKSRC}/${docfile} ${FASTA_DOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>