aboutsummaryrefslogtreecommitdiff
path: root/biology/genpak/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-28 02:46:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-02-28 02:46:51 +0000
commit384048cae5f466e49a9208e8cc1c025638c3306e (patch)
tree49d343ea69be67f5ceed08406ac840875565da29 /biology/genpak/Makefile
parentd87d30e4840ace9dfdb95e53251a1a2b30407b24 (diff)
downloadports-384048cae5f466e49a9208e8cc1c025638c3306e.tar.gz
ports-384048cae5f466e49a9208e8cc1c025638c3306e.zip
Notes
Diffstat (limited to 'biology/genpak/Makefile')
-rw-r--r--biology/genpak/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/biology/genpak/Makefile b/biology/genpak/Makefile
new file mode 100644
index 000000000000..3b7b60a6695b
--- /dev/null
+++ b/biology/genpak/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# New ports collection makefile for: genpak
+# Date created: Feb 28, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= genpak
+PORTVERSION= 0.25
+CATEGORIES= biology
+MASTER_SITES= http://www.bioinformatics.org/genpak/download/
+DISTNAME= gp-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd \
+ png.4:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+
+MAN1= Genpak.1 gp_acc.1 gp_cusage.1 gp_digest.1 gp_dimer.1 gp_findorf.1 \
+ gp_gc.1 gp_getseq.1 gp_matrix.1 gp_mkmtx.1 gp_pattern.1 gp_qs.1 \
+ gp_randseq.1 gp_seq2prot.1 gp_slen.1 gp_tm.1 gp_trimer.1 gp_primer.1
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install docs
+.endif
+
+post-patch:
+ @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%MANPREFIX%%|${MANPREFIX}|g ; \
+ s|%%DOCDIR%%|${PREFIX}/share/doc|g ; \
+ s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>