aboutsummaryrefslogtreecommitdiff
path: root/biology/gperiodic
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-02 09:05:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-02 09:05:22 +0000
commitda9f175a158f24798b8c80376d8af5c2805990df (patch)
tree0ed1f0b8a33b721d42f19aad0c092dd31d7238cb /biology/gperiodic
parente336fa07f52025dcc028e68cca95037f5b3b0098 (diff)
downloadports-da9f175a158f24798b8c80376d8af5c2805990df.tar.gz
ports-da9f175a158f24798b8c80376d8af5c2805990df.zip
Notes
Diffstat (limited to 'biology/gperiodic')
-rw-r--r--biology/gperiodic/Makefile16
-rw-r--r--biology/gperiodic/pkg-plist16
2 files changed, 22 insertions, 10 deletions
diff --git a/biology/gperiodic/Makefile b/biology/gperiodic/Makefile
index 251a0cad7b22..732d3072b28e 100644
--- a/biology/gperiodic/Makefile
+++ b/biology/gperiodic/Makefile
@@ -11,18 +11,26 @@ MASTER_SITES= http://www.frantz.fi/software/
MAINTAINER= ports@FreeBSD.org
COMMENT= Displays a periodic table of the elements
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/gpl.txt
+
USE_GNOME= gtk20
-USES= gettext pkgconfig
+USES= pkgconfig
LANGS= da fr gl it pl ru sv tr
PORTDOCS= AUTHORS ChangeLog README
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} `pkg-config --cflags --libs gtk+-2.0` \
gperiodic.c -o gperiodic
+
+do-build-NLS-on:
.for lang in ${LANGS}
cd ${WRKSRC}/po && msgfmt -f -v -o ${lang}.mo ${lang}.po
.endfor
@@ -33,11 +41,15 @@ do-install:
${STAGEDIR}${PREFIX}/share/applications
(cd ${WRKSRC} && ${INSTALL_DATA} gperiodic.png gperiodic-crystal.png \
${STAGEDIR}${PREFIX}/share/pixmaps)
+
+do-install-NLS-on:
.for lang in ${LANGS}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \
${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo
.endfor
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/biology/gperiodic/pkg-plist b/biology/gperiodic/pkg-plist
index 0520be903881..22ba3a5d6e5c 100644
--- a/biology/gperiodic/pkg-plist
+++ b/biology/gperiodic/pkg-plist
@@ -1,12 +1,12 @@
bin/gperiodic
share/applications/gperiodic.desktop
-share/locale/da/LC_MESSAGES/gperiodic.mo
-share/locale/fr/LC_MESSAGES/gperiodic.mo
-share/locale/gl/LC_MESSAGES/gperiodic.mo
-share/locale/it/LC_MESSAGES/gperiodic.mo
-share/locale/pl/LC_MESSAGES/gperiodic.mo
-share/locale/ru/LC_MESSAGES/gperiodic.mo
-share/locale/sv/LC_MESSAGES/gperiodic.mo
-share/locale/tr/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gperiodic.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gperiodic.mo
share/pixmaps/gperiodic.png
share/pixmaps/gperiodic-crystal.png