aboutsummaryrefslogtreecommitdiff
path: root/biology/infernal
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-27 17:57:14 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-01-27 17:57:14 +0000
commit03b31d441635bfd39baf917503199a4f64660026 (patch)
tree9430b2652b8aefe931e86b5fba456ae4cbc37e44 /biology/infernal
parent27efe6fe0534beea30cf14104518b00a5257b22e (diff)
downloadports-03b31d441635bfd39baf917503199a4f64660026.tar.gz
ports-03b31d441635bfd39baf917503199a4f64660026.zip
Notes
Diffstat (limited to 'biology/infernal')
-rw-r--r--biology/infernal/Makefile29
-rw-r--r--biology/infernal/distinfo6
-rw-r--r--biology/infernal/files/patch-configure10
-rw-r--r--biology/infernal/files/patch-hmmer_src_hmmc2.c11
-rw-r--r--biology/infernal/files/patch-src_Makefile.in19
5 files changed, 53 insertions, 22 deletions
diff --git a/biology/infernal/Makefile b/biology/infernal/Makefile
index 9e65537af33d..8ecde37b71ac 100644
--- a/biology/infernal/Makefile
+++ b/biology/infernal/Makefile
@@ -1,23 +1,31 @@
# $FreeBSD$
PORTNAME= infernal
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= biology
MASTER_SITES= http://eddylab.org/infernal/
-MAINTAINER= mzaki@niid.go.jp
+MAINTAINER= mzaki@e-mail.ne.jp
COMMENT= Search sequence databases for structural RNA homologs
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64 i386 powerpc64
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 powerpcspe
ONLY_FOR_ARCHS_REASON= requires SSE2 or AltiVec instructions
-USES= gmake
+USES= compiler:c11 gmake perl5 python:3.5+,test shebangfix
+
GNU_CONFIGURE= yes
MAKE_ARGS= V=1
+TEST_TARGET= check
+USE_PERL5= test
+SHEBANG_GLOB= *.pl *.py
+SHEBANG_FILES= easel/devkit/*
+
+OPTIONS_DEFINE= DOCS EXAMPLES TEST
+
DOCFILES= Userguide.pdf
EXAMPLES= 5S_rRNA.c.cm 5S_rRNA.sto \
Cobalamin.c.cm Cobalamin.fa Cobalamin.sto \
@@ -27,13 +35,16 @@ EXAMPLES= 5S_rRNA.c.cm 5S_rRNA.sto \
tRNA5-hand.c.cm tRNA5-hand.sto tRNA5-mrum.out \
tRNA5-noss.sto tRNA5.c.cm tRNA5.sto
-OPTIONS_DEFINE= DOCS EXAMPLES TEST
+TEST_VARS= use_perl5=build
+TEST_BUILD_DEPENDS= ${PYTHON_VERSION}:lang/python${PYTHON_SUFFIX}
+
+post-build-TEST-on: pre-test do-test
-TEST_TEST_TARGET= check
-TEST_USES= shebangfix perl5
-TEST_VARS= shebang_glob=*.pl shebang_files=easel/devkit/* use_perl5=build
+pre-test:
+ ${FIND} ${WRKSRC} -type f \( -name Makefile -or -name sqc \) -exec ${GREP} -q 'python3 ' {} \; -print | ${XARGS} ${SED} -i.bak 's/python3 /${PYTHON_VERSION} /'
-post-build-TEST-on: do-test
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/biology/infernal/distinfo b/biology/infernal/distinfo
index a99bece6070f..9f362448abc8 100644
--- a/biology/infernal/distinfo
+++ b/biology/infernal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528251928
-SHA256 (infernal-1.1.2.tar.gz) = ac8c24f484205cfb7124c38d6dc638a28f2b9035b9433efec5dc753c7e84226b
-SIZE (infernal-1.1.2.tar.gz) = 19364073
+TIMESTAMP = 1578660730
+SHA256 (infernal-1.1.3.tar.gz) = 3b98a6a3a0e7b01aa077a0caf1e958223c4d8f80a69a4eb602ca59a3475da85e
+SIZE (infernal-1.1.3.tar.gz) = 29910035
diff --git a/biology/infernal/files/patch-configure b/biology/infernal/files/patch-configure
deleted file mode 100644
index f9fdfd5f3f0d..000000000000
--- a/biology/infernal/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig 2016-07-01 20:26:34 UTC
-+++ configure
-@@ -3855,6 +3855,7 @@ fi
- if test "$impl_choice" = "none"; then
- case $host in
- ia64-*-*) impl_choice=sse;;
-+ amd64-*-*) impl_choice=sse;;
- i?86-*-*) impl_choice=sse;;
- x86*-*-*) impl_choice=sse;;
- powerpc*-*-*) impl_choice=vmx;;
diff --git a/biology/infernal/files/patch-hmmer_src_hmmc2.c b/biology/infernal/files/patch-hmmer_src_hmmc2.c
new file mode 100644
index 000000000000..5bd86cf55247
--- /dev/null
+++ b/biology/infernal/files/patch-hmmer_src_hmmc2.c
@@ -0,0 +1,11 @@
+--- hmmer/src/hmmc2.c.orig 2019-11-19 19:30:04 UTC
++++ hmmer/src/hmmc2.c
+@@ -334,7 +334,7 @@ int main(int argc, char *argv[])
+ n = sizeof(sstatus);
+ total += n;
+ if ((size = readn(sock, &sstatus, n)) == -1) {
+- if(errno == 104 || errno == 0){
++ if(errno == ECONNRESET || errno == 0){
+ // connection was reset, usually because server exited
+ fprintf(stderr, "Daemon exited, shutting down\n");
+ exit(0);
diff --git a/biology/infernal/files/patch-src_Makefile.in b/biology/infernal/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..7afaa0ab41ea
--- /dev/null
+++ b/biology/infernal/files/patch-src_Makefile.in
@@ -0,0 +1,19 @@
+--- src/Makefile.in.orig 2019-11-19 19:28:55 UTC
++++ src/Makefile.in
+@@ -27,6 +27,7 @@ CC = @CC@
+ CFLAGS = @CFLAGS@
+ PTHREAD_CFLAGS = @PTHREAD_CFLAGS@
+ PIC_CFLAGS = @PIC_CFLAGS@
++SIMD_CFLAGS = @SSE_CFLAGS@ @VMX_CFLAGS@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ DEFS = @DEFS@
+@@ -200,7 +201,7 @@ ${PROGS}: % : %.o libinfernal.a ../${HMM
+ ${QUIET_GEN}${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PIC_CFLAGS} ${DEFS} ${LDFLAGS} ${MYLIBDIRS} -o $@ $@.o ${MPILIBS} ${LIBS}
+
+ .c.o:
+- ${QUIET_CC}${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PIC_CFLAGS} ${DEFS} ${CPPFLAGS} ${MYINCDIRS} -o $@ -c $<
++ ${QUIET_CC}${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PIC_CFLAGS} ${SIMD_CFLAGS} ${DEFS} ${CPPFLAGS} ${MYINCDIRS} -o $@ -c $<
+
+ ${ITESTS}: % : %.o libinfernal.a ../${HMMERDIR}/src/libhmmer.a ../${ESLDIR}/libeasel.a ${HDRS} config.h
+ ${QUIET_GEN}${CC} ${CFLAGS} ${PTHREAD_CFLAGS} ${PIC_CFLAGS} ${DEFS} ${LDFLAGS} ${MYLIBDIRS} -o $@ $@.o ${MPILIBS} ${LIBS}