aboutsummaryrefslogtreecommitdiff
path: root/biology/lagan
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-11-15 07:04:29 +0000
committerWen Heping <wen@FreeBSD.org>2012-11-15 07:04:29 +0000
commit2a3cdaf773b056ed1e741d7126ec2bc4557616b6 (patch)
tree54e3d63be05023ffab4b3dc4bb70cde9cbd55ce9 /biology/lagan
parent8a810e1148599d332ee1784105e0439f65ecd8f6 (diff)
downloadports-2a3cdaf773b056ed1e741d7126ec2bc4557616b6.tar.gz
ports-2a3cdaf773b056ed1e741d7126ec2bc4557616b6.zip
Notes
Diffstat (limited to 'biology/lagan')
-rw-r--r--biology/lagan/Makefile37
-rw-r--r--biology/lagan/distinfo4
-rw-r--r--biology/lagan/files/patch-src__glocal__score.cpp11
-rw-r--r--biology/lagan/files/patch-src__utils__Glue.cpp10
-rw-r--r--biology/lagan/pkg-descr33
-rw-r--r--biology/lagan/pkg-plist45
6 files changed, 60 insertions, 80 deletions
diff --git a/biology/lagan/Makefile b/biology/lagan/Makefile
index 574fef7c771e..d9e44294e52c 100644
--- a/biology/lagan/Makefile
+++ b/biology/lagan/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lagan
-PORTVERSION= 1.2
+PORTVERSION= 2.0
CATEGORIES= biology
MASTER_SITES= http://lagan.stanford.edu/lagan_web/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -10,10 +10,23 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Efficient tools for large-scale multiple alignments of genomic DNA
-LAGAN_DIR= ${PREFIX}/${PORTNAME}
+LICENSE= GPLv2
+
USE_PERL5_RUN= yes
+MAKE_JOBS_UNSAFE=yes
+
SUB_FILES= pkg-message
-SUB_LIST= LAGAN_DIR=${LAGAN_DIR}
+SUB_LIST= LAGAN_DIR="${LAGAN_DIR}"
+
+PLIST_FILES= ${EXECUTABLES:S,^,${PORTNAME}/,} \
+ ${SCRIPTS:S,^,${PORTNAME}/,} \
+ ${EXEUTILS:S,^,${PORTNAME}/utils/,} \
+ ${SCRIPTUTILS:S,^,${PORTNAME}/utils/,} \
+ ${READMES:S,^,${PORTNAME}/Readmes/,}
+PLIST_DIRS= ${PORTNAME}/utils ${PORTNAME}/Readmes
+PLIST_DIRSTRY= ${PORTNAME}
+
+LAGAN_DIR= ${PREFIX}/${PORTNAME}
EXECUTABLES= anchors chaos glocal mlagan order
SCRIPTS= anal_gloc.pl lagan.pl rechaos.pl slagan.pl
@@ -22,17 +35,19 @@ EXEUTILS= Glue bin2bl bin2mf cextract contigorder cstat dotplot fa2xfa \
scorecontigs seqmerge
SCRIPTUTILS= cmerge2.pl draft.pl mextract.pl mf2bin.pl mpretty.pl \
mproject.pl mrun.pl mrunfile.pl mrunpairs.pl mviz.pl
-
-CC:= ${CC} ${CFLAGS}
-CPP= ${CXX} ${CXXFLAGS}
+READMES= README.FIRST README.chaos README.lagan README.mlagan \
+ README.tools README.shuffle
post-patch:
- @${REINPLACE_CMD} -E 's,^(CC|CPP) =,\1 ?=,g' \
- ${WRKSRC}/Makefile
+ @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
+ '/^CC/s|^|#| ; \
+ /^CFLAGS/s|^|#| ; \
+ s|$$(CC) -o|$$(CC) $$(CFLAGS) -o| ; \
+ s|$$(CPP) -o|$$(CXX) $$(CXXFLAGS) -o| ; \
+ s|$$(CLINKER) $$(OPTFLAGS)|$$(CXX) $$(LDFLAGS)|'
do-install:
@${MKDIR} ${LAGAN_DIR}
- ${CP} -R ${WRKSRC}/Readmes ${LAGAN_DIR}
.for exe in ${EXECUTABLES}
${INSTALL_PROGRAM} ${WRKSRC}/${exe} ${LAGAN_DIR}
.endfor
@@ -46,6 +61,10 @@ do-install:
.for scriptutil in ${SCRIPTUTILS}
${INSTALL_SCRIPT} ${WRKSRC}/utils/${scriptutil} ${LAGAN_DIR}/utils
.endfor
+ @${MKDIR} ${LAGAN_DIR}/Readmes
+.for readme in ${READMES}
+ ${INSTALL_DATA} ${WRKSRC}/Readmes/${readme} ${LAGAN_DIR}/Readmes
+.endfor
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/biology/lagan/distinfo b/biology/lagan/distinfo
index ddb81f9ea03f..ca3f96cf5715 100644
--- a/biology/lagan/distinfo
+++ b/biology/lagan/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lagan12.tar.gz) = d27754367b3aa9bf34976f7a619d5024be444b47cba370e3f53d0bba87389d4a
-SIZE (lagan12.tar.gz) = 112894
+SHA256 (lagan20.tar.gz) = a65e61ed4fd6608f4e5ad5b11a1b77f4fec1a207d822c5885b3e86727496e1fe
+SIZE (lagan20.tar.gz) = 589115
diff --git a/biology/lagan/files/patch-src__glocal__score.cpp b/biology/lagan/files/patch-src__glocal__score.cpp
new file mode 100644
index 000000000000..76a8521558ab
--- /dev/null
+++ b/biology/lagan/files/patch-src__glocal__score.cpp
@@ -0,0 +1,11 @@
+--- src/glocal/score.cpp.orig 2006-09-15 05:40:19.000000000 +0900
++++ src/glocal/score.cpp 2012-10-03 00:22:50.000000000 +0900
+@@ -2,7 +2,7 @@
+ #include<score.h>
+ #include<leftinfluence.h>
+ #include<rightinfluence.h>
+-#include<fstream.h>
++#include<fstream>
+
+ extern vector<class Score*> scoreFunctions[1<<(UPSTRANDBITS+DOWNSTRANDBITS+RELPOSBITS)];
+
diff --git a/biology/lagan/files/patch-src__utils__Glue.cpp b/biology/lagan/files/patch-src__utils__Glue.cpp
new file mode 100644
index 000000000000..8b5b2b4fed25
--- /dev/null
+++ b/biology/lagan/files/patch-src__utils__Glue.cpp
@@ -0,0 +1,10 @@
+--- src/utils/Glue.cpp.orig 2006-09-15 05:40:18.000000000 +0900
++++ src/utils/Glue.cpp 2012-10-03 00:23:38.000000000 +0900
+@@ -6,6 +6,7 @@
+ #include <fstream>
+ #include <iostream>
+ #include <algorithm>
++#include <cstring>
+
+ #define NUCLEOTIDE_MATRIX_FILE "nucmatrix.txt"
+ #define MAX_LINE_LENGTH 1024
diff --git a/biology/lagan/pkg-descr b/biology/lagan/pkg-descr
index 33a4aae090be..b7dd5e856977 100644
--- a/biology/lagan/pkg-descr
+++ b/biology/lagan/pkg-descr
@@ -1,24 +1,9 @@
-The LAGAN Toolkit consists of four components:
-
- CHAOS, a pairwise local aligner optimized for non-coding, and other
- poorly conserved regions of the genome.
-
- LAGAN, a highly parametrizable pairwise global alignment using local
- alignments generated by CHAOS as anchors.
-
- Multi-LAGAN, a progressive pairwise algorithm to produce multiple
- sequence alignments.
-
- Shuffle-LAGAN, a novel glocal algorithm that is able to find
- rearrangements in a global alignment.
-
-Fast and sensitive multiple alignment of long genomic sequences. BMC
-Bioinformatics 2003 4:66.
-
-LAGAN and Multi-LAGAN: efficient tools for large-scale multiple
-alignment of genomic DNA. Genome Res 2003 13(4): 721-31.
-
-Glocal alignment: finding rearrangements during alignment. Proceedings
-of the ISMB 2003, Bioinformatics 19: 54i-62i.
-
-WWW: http://lagan.stanford.edu/lagan_web/
+The Lagan Tookit is a set of alignment programs for comparative
+genomics. The three main components are a pairwise aligner (LAGAN), a
+multiple aligner (M-LAGAN), and a glocal aligner (Shuffle-LAGAN). All
+three are based on the CHAOS local alignment tool and combine speed
+(regions up to several megabases can be aligned in minutes) with high
+accuracy. The results of the alignment can be visualized using the VISTA
+visualization tool.
+
+WWW: http://lagan.stanford.edu/
diff --git a/biology/lagan/pkg-plist b/biology/lagan/pkg-plist
deleted file mode 100644
index 5ee3d3202348..000000000000
--- a/biology/lagan/pkg-plist
+++ /dev/null
@@ -1,45 +0,0 @@
-lagan/Readmes/README.mlagan
-lagan/Readmes/README.FIRST
-lagan/Readmes/README.lagan
-lagan/Readmes/README.chaos
-lagan/Readmes/README.tools
-lagan/Readmes/README.shuffle
-lagan/Readmes/LICENSE
-lagan/anchors
-lagan/chaos
-lagan/glocal
-lagan/mlagan
-lagan/order
-lagan/anal_gloc.pl
-lagan/lagan.pl
-lagan/rechaos.pl
-lagan/slagan.pl
-lagan/utils/Glue
-lagan/utils/bin2bl
-lagan/utils/bin2mf
-lagan/utils/cextract
-lagan/utils/contigorder
-lagan/utils/cstat
-lagan/utils/dotplot
-lagan/utils/fa2xfa
-lagan/utils/getbounds
-lagan/utils/getcontigpos
-lagan/utils/getlength
-lagan/utils/getoverlap
-lagan/utils/rc
-lagan/utils/scorealign
-lagan/utils/scorecontigs
-lagan/utils/seqmerge
-lagan/utils/cmerge2.pl
-lagan/utils/draft.pl
-lagan/utils/mextract.pl
-lagan/utils/mf2bin.pl
-lagan/utils/mpretty.pl
-lagan/utils/mproject.pl
-lagan/utils/mrun.pl
-lagan/utils/mrunfile.pl
-lagan/utils/mrunpairs.pl
-lagan/utils/mviz.pl
-@dirrm lagan/Readmes
-@dirrmtry lagan/utils
-@dirrmtry lagan