aboutsummaryrefslogtreecommitdiff
path: root/biology/lagan
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-16 22:31:26 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-16 22:31:26 +0000
commit35642ebc86f022e57de659bbfb7502261d1e51b8 (patch)
tree32e973c8c1fa85cff7ff95bd0dc5e424ee34344a /biology/lagan
parentfb73445881ab950fdf2e120a93afa482f96412f0 (diff)
downloadports-35642ebc86f022e57de659bbfb7502261d1e51b8.tar.gz
ports-35642ebc86f022e57de659bbfb7502261d1e51b8.zip
Notes
Diffstat (limited to 'biology/lagan')
-rw-r--r--biology/lagan/Makefile54
-rw-r--r--biology/lagan/distinfo3
-rw-r--r--biology/lagan/files/pkg-message.in9
-rw-r--r--biology/lagan/pkg-descr24
-rw-r--r--biology/lagan/pkg-plist45
5 files changed, 135 insertions, 0 deletions
diff --git a/biology/lagan/Makefile b/biology/lagan/Makefile
new file mode 100644
index 000000000000..fdec41b76a0d
--- /dev/null
+++ b/biology/lagan/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: lagan
+# Date created: 07 Dec 2005
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lagan
+PORTVERSION= 1.2
+CATEGORIES= biology
+MASTER_SITES= http://lagan.stanford.edu/lagan_web/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Efficient tools for large-scale multiple alignments of genomic DNA
+
+LAGAN_DIR= ${PREFIX}/${PORTNAME}
+USE_PERL5_RUN= yes
+SUB_FILES= pkg-message
+SUB_LIST= LAGAN_DIR=${LAGAN_DIR}
+
+EXECUTABLES= anchors chaos glocal mlagan order
+SCRIPTS= anal_gloc.pl lagan.pl rechaos.pl slagan.pl
+EXEUTILS= Glue bin2bl bin2mf cextract contigorder cstat dotplot fa2xfa \
+ getbounds getcontigpos getlength getoverlap rc scorealign \
+ scorecontigs seqmerge
+SCRIPTUTILS= cmerge2.pl draft.pl mextract.pl mf2bin.pl mpretty.pl \
+ mproject.pl mrun.pl mrunfile.pl mrunpairs.pl mviz.pl
+
+MAKE_ENV+= CC="${CC} ${CFLAGS}" CPP="${CXX} ${CXXFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(CC|CPP) =,\1 ?=,g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${MKDIR} ${LAGAN_DIR}
+ ${CP} -R ${WRKSRC}/Readmes ${LAGAN_DIR}
+.for exe in ${EXECUTABLES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${exe} ${LAGAN_DIR}
+.endfor
+.for script in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${LAGAN_DIR}
+.endfor
+ @${MKDIR} ${LAGAN_DIR}/utils
+.for exeutil in ${EXEUTILS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/utils/${exeutil} ${LAGAN_DIR}/utils
+.endfor
+.for scriptutil in ${SCRIPTUTILS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/utils/${scriptutil} ${LAGAN_DIR}/utils
+.endfor
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/biology/lagan/distinfo b/biology/lagan/distinfo
new file mode 100644
index 000000000000..c190de38aa90
--- /dev/null
+++ b/biology/lagan/distinfo
@@ -0,0 +1,3 @@
+MD5 (lagan12.tar.gz) = e45c9287d04b31924115869588f1fb61
+SHA256 (lagan12.tar.gz) = d27754367b3aa9bf34976f7a619d5024be444b47cba370e3f53d0bba87389d4a
+SIZE (lagan12.tar.gz) = 112894
diff --git a/biology/lagan/files/pkg-message.in b/biology/lagan/files/pkg-message.in
new file mode 100644
index 000000000000..994a417239c8
--- /dev/null
+++ b/biology/lagan/files/pkg-message.in
@@ -0,0 +1,9 @@
+===============================================================================
+
+ All the executables, scripts, Readmes and utilities were installed
+ under %%LAGAN_DIR%%
+
+ Add this to your PATH and set the environment variable
+ LAGAN_DIR to point to this directory.
+
+===============================================================================
diff --git a/biology/lagan/pkg-descr b/biology/lagan/pkg-descr
new file mode 100644
index 000000000000..33a4aae090be
--- /dev/null
+++ b/biology/lagan/pkg-descr
@@ -0,0 +1,24 @@
+The LAGAN Toolkit consists of four components:
+
+ CHAOS, a pairwise local aligner optimized for non-coding, and other
+ poorly conserved regions of the genome.
+
+ LAGAN, a highly parametrizable pairwise global alignment using local
+ alignments generated by CHAOS as anchors.
+
+ Multi-LAGAN, a progressive pairwise algorithm to produce multiple
+ sequence alignments.
+
+ Shuffle-LAGAN, a novel glocal algorithm that is able to find
+ rearrangements in a global alignment.
+
+Fast and sensitive multiple alignment of long genomic sequences. BMC
+Bioinformatics 2003 4:66.
+
+LAGAN and Multi-LAGAN: efficient tools for large-scale multiple
+alignment of genomic DNA. Genome Res 2003 13(4): 721-31.
+
+Glocal alignment: finding rearrangements during alignment. Proceedings
+of the ISMB 2003, Bioinformatics 19: 54i-62i.
+
+WWW: http://lagan.stanford.edu/lagan_web/
diff --git a/biology/lagan/pkg-plist b/biology/lagan/pkg-plist
new file mode 100644
index 000000000000..5ee3d3202348
--- /dev/null
+++ b/biology/lagan/pkg-plist
@@ -0,0 +1,45 @@
+lagan/Readmes/README.mlagan
+lagan/Readmes/README.FIRST
+lagan/Readmes/README.lagan
+lagan/Readmes/README.chaos
+lagan/Readmes/README.tools
+lagan/Readmes/README.shuffle
+lagan/Readmes/LICENSE
+lagan/anchors
+lagan/chaos
+lagan/glocal
+lagan/mlagan
+lagan/order
+lagan/anal_gloc.pl
+lagan/lagan.pl
+lagan/rechaos.pl
+lagan/slagan.pl
+lagan/utils/Glue
+lagan/utils/bin2bl
+lagan/utils/bin2mf
+lagan/utils/cextract
+lagan/utils/contigorder
+lagan/utils/cstat
+lagan/utils/dotplot
+lagan/utils/fa2xfa
+lagan/utils/getbounds
+lagan/utils/getcontigpos
+lagan/utils/getlength
+lagan/utils/getoverlap
+lagan/utils/rc
+lagan/utils/scorealign
+lagan/utils/scorecontigs
+lagan/utils/seqmerge
+lagan/utils/cmerge2.pl
+lagan/utils/draft.pl
+lagan/utils/mextract.pl
+lagan/utils/mf2bin.pl
+lagan/utils/mpretty.pl
+lagan/utils/mproject.pl
+lagan/utils/mrun.pl
+lagan/utils/mrunfile.pl
+lagan/utils/mrunpairs.pl
+lagan/utils/mviz.pl
+@dirrm lagan/Readmes
+@dirrmtry lagan/utils
+@dirrmtry lagan