aboutsummaryrefslogtreecommitdiff
path: root/biology/lamarc
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-17 20:22:32 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-17 20:22:32 +0000
commit4e26180092f225a91febc56308bb4d8af08bfca0 (patch)
treedc1f6373fe8ed8a9ef5fa9a13dcfd8b000bd1038 /biology/lamarc
parent17db0552682701ad60c41416a1ab5f61e0b7d17a (diff)
downloadports-4e26180092f225a91febc56308bb4d8af08bfca0.tar.gz
ports-4e26180092f225a91febc56308bb4d8af08bfca0.zip
Notes
Diffstat (limited to 'biology/lamarc')
-rw-r--r--biology/lamarc/Makefile29
-rw-r--r--biology/lamarc/distinfo4
-rw-r--r--biology/lamarc/files/patch-Makefile.in47
-rw-r--r--biology/lamarc/files/patch-configure11
-rw-r--r--biology/lamarc/files/patch-src__control__defaults.h11
-rw-r--r--biology/lamarc/pkg-plist90
6 files changed, 21 insertions, 171 deletions
diff --git a/biology/lamarc/Makefile b/biology/lamarc/Makefile
index f3a9e3e04398..4d4305fa493c 100644
--- a/biology/lamarc/Makefile
+++ b/biology/lamarc/Makefile
@@ -6,34 +6,43 @@
#
PORTNAME= lamarc
-PORTVERSION= 2.1.5
+PORTVERSION= 2.1.8
+DISTVERSIONSUFFIX= -src
PORTEPOCH= 1
CATEGORIES= biology
-MASTER_SITES= http://evolution.gs.washington.edu/lamarc/download/
-EXTRACT_SUFX= .src.tar.gz
+MASTER_SITES= http://evolution.genetics.washington.edu/lamarc/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= A package of programs for computing population parameters
LICENSE= AL2
-OPTIONS= WXGTK2 "Install wxWidgets" off
+OPTIONS_DEFINE= WXGTK DOCS
-MAKE_JOBS_SAFE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:S,${DISTVERSIONSUFFIX},,}
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= *
+PLIST_FILES= bin/${PORTNAME}
-.if defined(WITH_WXGTK2)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWXGTK}
USE_WX= 2.8
-CONFIGURE_ARGS+= --with-wx-config=${WX_CONFIG}
-PLIST_SUB+= WXGTK2=""
+WX_CONF_ARGS= absolute
+PLIST_FILES+= bin/lam_conv
.else
CONFIGURE_ARGS+= --disable-converter
-PLIST_SUB+= WXGTK2="@comment "
.endif
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
INSTALL_TARGET= install-exec-am
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/html/lamarc|/${DOCSDIR_REL}|' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/biology/lamarc/distinfo b/biology/lamarc/distinfo
index dde10bd5e77b..a199e1c15a8f 100644
--- a/biology/lamarc/distinfo
+++ b/biology/lamarc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lamarc-2.1.5.src.tar.gz) = 4cf0f44f16742cf32e16aeb88b3116490b78d099dace0fd1ae191fbc7f4c7cf0
-SIZE (lamarc-2.1.5.src.tar.gz) = 24328427
+SHA256 (lamarc-2.1.8-src.tar.gz) = 73ca99a87c5d40577c3d3fbc25b72e3507bfce22f5376dfec90fd3a90b085281
+SIZE (lamarc-2.1.8-src.tar.gz) = 24919620
diff --git a/biology/lamarc/files/patch-Makefile.in b/biology/lamarc/files/patch-Makefile.in
deleted file mode 100644
index 742dd9f7a8ae..000000000000
--- a/biology/lamarc/files/patch-Makefile.in
+++ /dev/null
@@ -1,47 +0,0 @@
---- Makefile.in.orig Fri Oct 5 06:17:37 2007
-+++ Makefile.in Sat Oct 13 00:44:22 2007
-@@ -2011,7 +2011,7 @@
- EXTRA_batch_lam_conv_SOURCES = $(tinyxml_suite)
- lam_conv_app_SOURCES =
- lamarc_app_SOURCES =
--htmldir = $(prefix)/html/lamarc
-+htmldir = $(prefix)/share/doc/lamarc
- html_DATA = \
- doc/html/bayes.html \
- doc/html/bayes_howto.html \
-@@ -2054,7 +2054,7 @@
- doc/html/viral_data.html \
- doc/html/xmlinput.html
-
--htmlimgdir = $(prefix)/html/lamarc/images
-+htmlimgdir = $(prefix)/share/doc/lamarc/images
- htmlimg_DATA = \
- doc/html/images/browser-gtk.gif \
- doc/html/images/correlated1.gif \
-@@ -2072,7 +2072,7 @@
- doc/html/images/uncorrelated.gif \
- doc/html/images/variably_correlated.gif
-
--htmlbconvdir = $(prefix)/html/lamarc/batch_converter
-+htmlbconvdir = $(prefix)/share/doc/lamarc/batch_converter
- htmlbconv_DATA = \
- doc/html/batch_converter/README.txt \
- doc/html/batch_converter/chrom1_lamarc.xml \
-@@ -2086,7 +2086,7 @@
- doc/html/batch_converter/exported-lamarc-input.xml \
- doc/html/batch_converter/sample-conv-cmd.xml
-
--htmlbconvimgdir = $(prefix)/html/lamarc/batch_converter/images
-+htmlbconvimgdir = $(prefix)/share/doc/lamarc/batch_converter/images
- htmlbconvimg_DATA = \
- doc/html/batch_converter/images/lam_conv_chrom1_export_file_selection.png \
- doc/html/batch_converter/images/lam_conv_chrom1_export_warn_1.png \
-@@ -2100,7 +2100,7 @@
- doc/html/batch_converter/images/lam_conv_chrom3_region_table.png \
- doc/html/batch_converter/images/lam_conv_chrom3_segment_snp.png
-
--htmltraitdir = $(prefix)/html/lamarc/trait_mapping
-+htmltraitdir = $(prefix)/share/doc/lamarc/trait_mapping
- htmltrait_DATA = \
- doc/html/trait_mapping/README.txt \
- doc/html/trait_mapping/lamarc-trait-input.xml \
diff --git a/biology/lamarc/files/patch-configure b/biology/lamarc/files/patch-configure
deleted file mode 100644
index 658b3e301d3f..000000000000
--- a/biology/lamarc/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Thu Oct 4 01:33:34 2007
-+++ configure Sat Oct 13 00:47:54 2007
-@@ -2029,7 +2029,7 @@
- LAMARC_CODE_OSTYPE=LAMARC_COMPILE_MACOSX
- fi
- ;;
-- linux*)
-+ freebsd*|linux*)
- if test "X${lamCONV}" = "Xyes" ; then
- if test "X${lamGUI}" = "Xyes" ; then
- if test "X${GUI_TOOLKIT}" = "X" ; then
diff --git a/biology/lamarc/files/patch-src__control__defaults.h b/biology/lamarc/files/patch-src__control__defaults.h
deleted file mode 100644
index 6c28dc27649e..000000000000
--- a/biology/lamarc/files/patch-src__control__defaults.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/control/defaults.h.orig Sat Apr 28 04:56:55 2007
-+++ src/control/defaults.h Thu Aug 30 17:31:51 2007
-@@ -243,7 +243,7 @@
- static const verbosity_type verbosity;
- static const verbosity_type progress;
-
-- static const long programstarttime;
-+ static const time_t programstarttime;
- static const long randomseed;
-
- static const bool plotpost;
diff --git a/biology/lamarc/pkg-plist b/biology/lamarc/pkg-plist
deleted file mode 100644
index 7496602b21b8..000000000000
--- a/biology/lamarc/pkg-plist
+++ /dev/null
@@ -1,90 +0,0 @@
-bin/lamarc
-%%WXGTK2%%bin/lam_conv
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom1.mig
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom1_lamarc.xml
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom2.mig
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom2_lamarc.xml
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom3_lamarc.xml
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom3_phase_cmd.xml
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom3microsat.mig
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/chrom3snp.mig
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/exported-lamarc-input.xml
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom1_export_file_selection.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom1_export_warn_1.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom1_input.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom1_segment_panel.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom2_segment1.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_error_map_position.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_error_phase_file_needed.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_input.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_region_panel.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_region_table.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/images/lam_conv_chrom3_segment_snp.png
-%%PORTDOCS%%%%DOCSDIR%%/batch_converter/sample-conv-cmd.xml
-%%PORTDOCS%%%%DOCSDIR%%/bayes.html
-%%PORTDOCS%%%%DOCSDIR%%/bayes_howto.html
-%%PORTDOCS%%%%DOCSDIR%%/changes.html
-%%PORTDOCS%%%%DOCSDIR%%/comparing_curvefiles.sxc
-%%PORTDOCS%%%%DOCSDIR%%/comparing_curvefiles.xls
-%%PORTDOCS%%%%DOCSDIR%%/compiling.html
-%%PORTDOCS%%%%DOCSDIR%%/converter.html
-%%PORTDOCS%%%%DOCSDIR%%/converter_cmd.html
-%%PORTDOCS%%%%DOCSDIR%%/curve-smoothing.html
-%%PORTDOCS%%%%DOCSDIR%%/data_models.html
-%%PORTDOCS%%%%DOCSDIR%%/data_required.html
-%%PORTDOCS%%%%DOCSDIR%%/forces.html
-%%PORTDOCS%%%%DOCSDIR%%/gamma.html
-%%PORTDOCS%%%%DOCSDIR%%/genetic_map.html
-%%PORTDOCS%%%%DOCSDIR%%/genotype.html
-%%PORTDOCS%%%%DOCSDIR%%/glossary.html
-%%PORTDOCS%%%%DOCSDIR%%/growthmenu.html
-%%PORTDOCS%%%%DOCSDIR%%/images/browser-gtk.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/correlated1.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/correlated2.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/gui_lam_conv.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/lam_conv.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/lamarc.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/loci-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/loci2-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/partitions-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/partitions2-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/populations-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/startup-gtk.png
-%%PORTDOCS%%%%DOCSDIR%%/images/tracer_trend.png
-%%PORTDOCS%%%%DOCSDIR%%/images/uncorrelated.gif
-%%PORTDOCS%%%%DOCSDIR%%/images/variably_correlated.gif
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/insumfile.2reg3rep.xml
-%%PORTDOCS%%%%DOCSDIR%%/insumfile.3rep.xml
-%%PORTDOCS%%%%DOCSDIR%%/limitations.html
-%%PORTDOCS%%%%DOCSDIR%%/mapping.html
-%%PORTDOCS%%%%DOCSDIR%%/menu.html
-%%PORTDOCS%%%%DOCSDIR%%/messages.html
-%%PORTDOCS%%%%DOCSDIR%%/output.html
-%%PORTDOCS%%%%DOCSDIR%%/outsumfile.2reg3rep.xml
-%%PORTDOCS%%%%DOCSDIR%%/outsumfile.3rep.xml
-%%PORTDOCS%%%%DOCSDIR%%/overview.html
-%%PORTDOCS%%%%DOCSDIR%%/parallel.html
-%%PORTDOCS%%%%DOCSDIR%%/parameters.html
-%%PORTDOCS%%%%DOCSDIR%%/regions.html
-%%PORTDOCS%%%%DOCSDIR%%/search.html
-%%PORTDOCS%%%%DOCSDIR%%/tracer.html
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/lamarc-trait-input.xml
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/mapfile_funny-nose.txt
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/outfile.txt
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/traitCmd.xml
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/traitCmd.xml.txt
-%%PORTDOCS%%%%DOCSDIR%%/trait_mapping/traitData.mig
-%%PORTDOCS%%%%DOCSDIR%%/troubleshooting.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial.html
-%%PORTDOCS%%%%DOCSDIR%%/tutorial2.html
-%%PORTDOCS%%%%DOCSDIR%%/upcoming.html
-%%PORTDOCS%%%%DOCSDIR%%/viral_data.html
-%%PORTDOCS%%%%DOCSDIR%%/xmlinput.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/trait_mapping
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/batch_converter/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/batch_converter
-%%PORTDOCS%%@dirrm %%DOCSDIR%%