aboutsummaryrefslogtreecommitdiff
path: root/biology/libsbml
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-05-13 07:04:17 +0000
committerWen Heping <wen@FreeBSD.org>2014-05-13 07:04:17 +0000
commit06e1e7ab8b139b516085d7c4979b366496d45779 (patch)
treebb75448d00aa65850fe0840f14e6ead8d80db274 /biology/libsbml
parent85946fbf1a9c51c2037cef8328dbe1a2a7a87371 (diff)
downloadports-06e1e7ab8b139b516085d7c4979b366496d45779.tar.gz
ports-06e1e7ab8b139b516085d7c4979b366496d45779.zip
- Update to 5.10.0
Notes
Notes: svn path=/head/; revision=353921
Diffstat (limited to 'biology/libsbml')
-rw-r--r--biology/libsbml/Makefile4
-rw-r--r--biology/libsbml/distinfo4
-rw-r--r--biology/libsbml/pkg-plist37
3 files changed, 39 insertions, 6 deletions
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 70cb0f106a51..1a872b6be81f 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libsbml
-PORTVERSION= 5.9.0
+PORTVERSION= 5.10.0
CATEGORIES= biology devel
MASTER_SITES= SF
MASTER_SITE_SUBDIR= sbml/${PORTNAME}/${PORTVERSION}/stable
@@ -17,7 +17,7 @@ LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
OPTIONS_DEFINE= PYTHON RUBY EXAMPLES
-USES= gmake
+USES= gmake libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/biology/libsbml/distinfo b/biology/libsbml/distinfo
index 4c120e52aa61..f44159ea4470 100644
--- a/biology/libsbml/distinfo
+++ b/biology/libsbml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libSBML-5.9.0-core-src.tar.gz) = 8991e4a6876721999433495b747b790af7981ae57b485e6c92b7fbb105bd7e96
-SIZE (libSBML-5.9.0-core-src.tar.gz) = 11478158
+SHA256 (libSBML-5.10.0-core-src.tar.gz) = c7e733443caaf4615e90a29111ff988b89b1c9a679de0a9737fc2a86840df1e0
+SIZE (libSBML-5.10.0-core-src.tar.gz) = 11577010
diff --git a/biology/libsbml/pkg-plist b/biology/libsbml/pkg-plist
index e4ae42a570dd..cd9f9ff63e31 100644
--- a/biology/libsbml/pkg-plist
+++ b/biology/libsbml/pkg-plist
@@ -137,6 +137,7 @@ include/sbml/conversion/SBMLInferUnitsConverter.h
include/sbml/conversion/SBMLInitialAssignmentConverter.h
include/sbml/conversion/SBMLLevelVersionConverter.h
include/sbml/conversion/SBMLLocalParameterConverter.h
+include/sbml/conversion/SBMLReactionConverter.h
include/sbml/conversion/SBMLRuleConverter.h
include/sbml/conversion/SBMLStripPackageConverter.h
include/sbml/conversion/SBMLUnitsConverter.h
@@ -165,9 +166,9 @@ include/sbml/validator/SBMLInternalValidator.h
include/sbml/validator/SBMLValidator.h
include/sbml/xml/XMLConstructorException.h
include/sbml/xml/XMLLogOverride.h
-lib/libsbml.so.14
+lib/libsbml.so.5.10.0
+lib/libsbml.so.5
lib/libsbml.so
-lib/libsbml.la
lib/libsbml.a
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/libsbml/_libsbml.so
%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/libsbml.pth
@@ -489,3 +490,35 @@ lib/libsbml.a
@dirrm include/sbml/validator
@dirrm include/sbml/xml
@dirrm include/sbml/
+include/sbml/extension/ASTBasePlugin.h
+include/sbml/math/ASTBase.h
+include/sbml/math/ASTBinaryFunctionNode.h
+include/sbml/math/ASTCSymbol.h
+include/sbml/math/ASTCSymbolAvogadroNode.h
+include/sbml/math/ASTCSymbolDelayNode.h
+include/sbml/math/ASTCSymbolTimeNode.h
+include/sbml/math/ASTCiFunctionNode.h
+include/sbml/math/ASTCiNumberNode.h
+include/sbml/math/ASTCnBase.h
+include/sbml/math/ASTCnExponentialNode.h
+include/sbml/math/ASTCnIntegerNode.h
+include/sbml/math/ASTCnRationalNode.h
+include/sbml/math/ASTCnRealNode.h
+include/sbml/math/ASTConstantNumberNode.h
+include/sbml/math/ASTFunction.h
+include/sbml/math/ASTFunctionBase.h
+include/sbml/math/ASTLambdaFunctionNode.h
+include/sbml/math/ASTNaryFunctionNode.h
+include/sbml/math/ASTNumber.h
+include/sbml/math/ASTPiecewiseFunctionNode.h
+include/sbml/math/ASTQualifierNode.h
+include/sbml/math/ASTSemanticsNode.h
+include/sbml/math/ASTTypes.h
+include/sbml/math/ASTUnaryFunctionNode.h
+include/sbml/util/PrefixTransformer.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/convertReactions.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c++/layout/CMakeLists.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/csharp/layout/CMakeLists.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/java/layout/CMakeLists.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout-package.cmake
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/layout/convertLayout.py