aboutsummaryrefslogtreecommitdiff
path: root/biology/libsbml
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-09-23 01:06:29 +0000
committerWen Heping <wen@FreeBSD.org>2009-09-23 01:06:29 +0000
commit9c55d004d3fd8326d86a6da86b30c0e687b7ff23 (patch)
tree6e4ded63b116743551358b6157bbc4c193c27833 /biology/libsbml
parent2feeefa84344d243d6bd69d07f69ff9516b2be8c (diff)
downloadports-9c55d004d3fd8326d86a6da86b30c0e687b7ff23.tar.gz
ports-9c55d004d3fd8326d86a6da86b30c0e687b7ff23.zip
Notes
Diffstat (limited to 'biology/libsbml')
-rw-r--r--biology/libsbml/Makefile11
-rw-r--r--biology/libsbml/distinfo6
-rw-r--r--biology/libsbml/files/patch-Makefile.in12
-rw-r--r--biology/libsbml/pkg-plist7
4 files changed, 23 insertions, 13 deletions
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index eb43da5ee376..35c26f6cf234 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -6,12 +6,13 @@
#
PORTNAME= libsbml
-PORTVERSION= 3.3.2
+PORTVERSION= 4.0.0
CATEGORIES= biology devel
-MASTER_SITES= SF/sbml/${PORTNAME}/${PORTVERSION}
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= sbml/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-MAINTAINER= wenheping@gmail.com
+MAINTAINER= wen@FreeBSD.org
COMMENT= An API Library for Working with SBML File
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
@@ -45,6 +46,10 @@ PLIST_SUB+= WITH_RUBY=""
PLIST_SUB+= WITH_RUBY="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's#%%PREFIX%%#${PREFIX}#' \
+ ${WRKSRC}/Makefile.in
+
post-install:
.if !defined(NOPORTEXAMPLES)
${MKDIR} ${EXAMPLESDIR}
diff --git a/biology/libsbml/distinfo b/biology/libsbml/distinfo
index a54dd0635d09..8b520435b9b1 100644
--- a/biology/libsbml/distinfo
+++ b/biology/libsbml/distinfo
@@ -1,3 +1,3 @@
-MD5 (libsbml-3.3.2-src.zip) = f8b3ff297848f8cf0918c065f8a65133
-SHA256 (libsbml-3.3.2-src.zip) = 5ebd8a57679fda954032e44111fdbcb8dc8598037354962d82a1742b621505d4
-SIZE (libsbml-3.3.2-src.zip) = 7076694
+MD5 (libsbml-4.0.0-src.zip) = 998514886c132f042d6c35a6c57dbd9e
+SHA256 (libsbml-4.0.0-src.zip) = 7276efced3f41169384e59653b55796e7cf1c8c7f3c38b45d46316a6642d6cbd
+SIZE (libsbml-4.0.0-src.zip) = 8109512
diff --git a/biology/libsbml/files/patch-Makefile.in b/biology/libsbml/files/patch-Makefile.in
index 309111070348..db9ad2cb6215 100644
--- a/biology/libsbml/files/patch-Makefile.in
+++ b/biology/libsbml/files/patch-Makefile.in
@@ -5,7 +5,7 @@
install-pc: libsbml.pc
- $(INSTALL_SH) libsbml.pc -m 0644 "$(DESTDIR)$(LIBDIR)/pkgconfig/libsbml.pc"
-+ $(INSTALL_SH) libsbml.pc -m 0644 "/usr/local/libdata/pkgconfig/libsbml.pc"
++ $(INSTALL_SH) libsbml.pc -m 0644 "%%PREFIX%%/libdata/pkgconfig/libsbml.pc"
install-la: libsbml.la
ifeq "$(HOST_TYPE)" "cygwin"
@@ -14,21 +14,21 @@
uninstall-libsbml-pc:
- @target="$(DESTDIR)$(LIBDIR)/pkgconfig/libsbml.pc"; \
-+ @target="/usr/local/libdata/pkgconfig/libsbml.pc"; \
++ @target="%%PREFIX%%/libdata/pkgconfig/libsbml.pc"; \
if test -f $$target ; then \
echo rm $$target; \
rm $$target; \
fi; \
- if test -d "$(DESTDIR)$(LIBDIR)/pkgconfig"; then \
-+ if test -d "/usr/local/libdata/pkgconfig"; then \
++ if test -d "%%PREFIX%%/libdata/pkgconfig"; then \
if test -n "`find $(DESTDIR)$(LIBDIR) -maxdepth 0 -empty`"; then \
- echo rmdir "$(DESTDIR)$(LIBDIR)/pkgconfig"; \
- rmdir "$(DESTDIR)$(LIBDIR)/pkgconfig"; \
-+ echo rmdir "/usr/local/libdata/pkgconfig"; \
-+ rmdir "/usr/local/libdata/pkgconfig"; \
++ echo rmdir "%%PREFIX%%/libdata/pkgconfig"; \
++ rmdir "%%PREFIX%%/libdata/pkgconfig"; \
else \
- echo "Directory $(DESTDIR)$(LIBDIR)/pkgconfig not empty; leaving it alone"; \
-+ echo "Directory /usr/local/libdata/pkgconfig not empty; leaving it alone"; \
++ echo "Directory %%PREFIX%%/libdata/pkgconfig not empty; leaving it alone"; \
fi; \
fi;
diff --git a/biology/libsbml/pkg-plist b/biology/libsbml/pkg-plist
index 5a337b1f66fb..3a897153fb29 100644
--- a/biology/libsbml/pkg-plist
+++ b/biology/libsbml/pkg-plist
@@ -17,6 +17,7 @@ include/sbml/SBMLDocument.h
include/sbml/SBMLError.h
include/sbml/SBMLErrorLog.h
include/sbml/SBMLErrorTable.h
+include/sbml/SBMLNamespaces.h
include/sbml/SBMLReader.h
include/sbml/SBMLTypeCodes.h
include/sbml/SBMLTypes.h
@@ -28,6 +29,7 @@ include/sbml/Species.h
include/sbml/SpeciesReference.h
include/sbml/SpeciesType.h
include/sbml/StoichiometryMath.h
+include/sbml/SyntaxChecker.h
include/sbml/Trigger.h
include/sbml/Unit.h
include/sbml/UnitDefinition.h
@@ -40,7 +42,9 @@ include/sbml/common/extern.h
include/sbml/common/libsbml-config-unix.h
include/sbml/common/libsbml-config-win.h
include/sbml/common/libsbml-config.h
+include/sbml/common/libsbml-namespace.h
include/sbml/common/libsbml-version.h
+include/sbml/common/operationReturnValues.h
include/sbml/common/sbmlfwd.h
include/sbml/compress/CompressCommon.h
include/sbml/compress/InputDecompressor.h
@@ -110,8 +114,9 @@ include/sbml/xml/XMLParser.h
include/sbml/xml/XMLToken.h
include/sbml/xml/XMLTokenizer.h
include/sbml/xml/XMLTriple.h
-lib/libsbml.3.3.2.so
+lib/libsbml.so.4
lib/libsbml.so
+lib/libsbml.la
lib/libsbml.a
@dirrm include/sbml/annotation
@dirrm include/sbml/common