aboutsummaryrefslogtreecommitdiff
path: root/biology/molden/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-11-07 00:33:32 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-11-07 00:33:32 +0000
commitf481e858d925d05545c2c3dca2932b0d4c0689f4 (patch)
treeebd99a61cf78655b2f7c6f9a0768f95b6e52be20 /biology/molden/Makefile
parent54e40e7509f2502a391109ae454c21ed7f7e68cb (diff)
downloadports-f481e858d925d05545c2c3dca2932b0d4c0689f4.tar.gz
ports-f481e858d925d05545c2c3dca2932b0d4c0689f4.zip
Notes
Diffstat (limited to 'biology/molden/Makefile')
-rw-r--r--biology/molden/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 8f480a9a211e..14a33cc1e6ce 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -22,6 +22,10 @@ USE_FORTRAN= yes
RESTRICTED= free for academic, non profit usage; do not re-distribute source and executable.
MAKEFILE= ${WRKSRC}/makefile
+.if !defined(NOPORTDOCS)
+PORTDOCS= docs/*
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/xwin.c
@@ -38,12 +42,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gmolden ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/surf/surf ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/molden
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
${MKDIR} ${PREFIX}/share/molden/test
${MKDIR} ${PREFIX}/share/molden/utils
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/molden
${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/molden/test
${INSTALL_DATA} ${WRKSRC}/utils/* ${PREFIX}/share/molden/utils
-.endif
.include <bsd.port.mk>