aboutsummaryrefslogtreecommitdiff
path: root/biology/mummer/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 20:54:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 20:54:47 +0000
commit9326ebd9c8f7dca56b895434a70573b25074d3ca (patch)
treeb4c4f370929e142ab7221d42e764dc07b95b76c1 /biology/mummer/Makefile
parent255190e3c15db142ae191ac2504172b688f84275 (diff)
downloadports-9326ebd9c8f7dca56b895434a70573b25074d3ca.tar.gz
ports-9326ebd9c8f7dca56b895434a70573b25074d3ca.zip
Notes
Diffstat (limited to 'biology/mummer/Makefile')
-rw-r--r--biology/mummer/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/biology/mummer/Makefile b/biology/mummer/Makefile
new file mode 100644
index 000000000000..0b7a065c9eb7
--- /dev/null
+++ b/biology/mummer/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# New ports collection makefile for: MUMmer
+# Date created: 20 November 2007
+# Whom: Tony Maher
+#
+# $FreeBSD$
+#
+
+PORTNAME= mummer
+PORTVERSION= 3.20
+CATEGORIES= biology
+MASTER_SITES= SF
+DISTNAME= MUMmer${PORTVERSION}
+
+MAINTAINER= Anthony.Maher@uts.edu.au
+COMMENT= A modular system for rapid whole genome alignment
+
+USE_GMAKE= yes
+
+PROGRAMS= annotate combineMUMs delta-filter gaps \
+ mgaps mummer repeat-match show-aligns \
+ show-coords show-diff show-snps show-tiling
+SCRIPTS= dnadiff exact-tandems mapview mummerplot nucmer \
+ nucmer2xfig promer run-mummer1 run-mummer3
+DOCUMENTS= COPYRIGHT INSTALL LICENSE README
+
+do-install:
+.for program in ${PROGRAMS}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${program} ${PREFIX}/bin)
+.endfor
+
+.for script in ${SCRIPTS}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${script} ${PREFIX}/bin)
+.endfor
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCUMENTS}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${doc} ${DOCSDIR})
+.endfor
+.endif
+
+.include <bsd.port.mk>