aboutsummaryrefslogtreecommitdiff
path: root/biology/nab/files
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 13:49:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 13:49:54 +0000
commitfa382890590cbf8546df4850d2a560b966d1eee5 (patch)
tree803596d24799996b73d445cc4f1f743431a53d58 /biology/nab/files
parenta7587c0158677b0c247dadd7480edcec481f181a (diff)
Notes
Diffstat (limited to 'biology/nab/files')
-rw-r--r--biology/nab/files/Makefile6
-rw-r--r--biology/nab/files/Makefile.doc5
-rw-r--r--biology/nab/files/config.h58
-rw-r--r--biology/nab/files/patch-aa47
-rw-r--r--biology/nab/files/patch-ac25
-rw-r--r--biology/nab/files/patch-ad13
-rw-r--r--biology/nab/files/patch-ae19
-rw-r--r--biology/nab/files/patch-af23
-rw-r--r--biology/nab/files/patch-ag32
-rw-r--r--biology/nab/files/patch-ah19
-rw-r--r--biology/nab/files/patch-ai41
11 files changed, 73 insertions, 215 deletions
diff --git a/biology/nab/files/Makefile b/biology/nab/files/Makefile
deleted file mode 100644
index 79f216e09eb8..000000000000
--- a/biology/nab/files/Makefile
+++ /dev/null
@@ -1,6 +0,0 @@
-# $FreeBSD$
-#SUBDIR=cccp cifparse src
-SUBDIR=src tleap doc
-MAN1=nab.1
-
-.include <bsd.subdir.mk>
diff --git a/biology/nab/files/Makefile.doc b/biology/nab/files/Makefile.doc
deleted file mode 100644
index 279a1dcd4d88..000000000000
--- a/biology/nab/files/Makefile.doc
+++ /dev/null
@@ -1,5 +0,0 @@
-all:
-
-install:
- gzip -nfc -9 nab.1 > nab.1.gz
- ${INSTALL_MAN} ${WRKSRC}/doc/nab.1.gz ${PREFIX}/man/man1
diff --git a/biology/nab/files/config.h b/biology/nab/files/config.h
index d79236788f96..8166c22b49ce 100644
--- a/biology/nab/files/config.h
+++ b/biology/nab/files/config.h
@@ -1,7 +1,8 @@
###############################################################################
# Configuration section: look at sections (1) to (4) below, making
-# changes that seem necessary. For most UNIX systems, no changes
-# should be necessary.
+# changes that seem necessary. For many UNIX systems, no changes
+# should be necessary, but check especially the compiler options in
+# section (4).
#
###############################################################################
#
@@ -9,7 +10,7 @@
# make command line (e.g. "make ARCH=sun4 NABHOME=/thr/eigen/nab5")
# or as environment variables.
#
-# NABHOME should be an absolute path to the directory above this one.
+# NABHOME should be an absolute path to this directory.
# ARCH is used to distinguish compilations for various architectures.
#
# Files created by "make install" end up in:
@@ -20,12 +21,8 @@
# You can choose ARCH as you wish, but it would generally
# be related to the output of the "uname" command.
#
-#BINDIR=$(NABHOME)/bin/$(ARCH)
-#LIBDIR=$(NABHOME)/lib/$(ARCH)
-#NABHOME=/usr/local/share/nab
-#ARCH=
-BINDIR=$(NABHOME)/bin
-LIBDIR=$(NABHOME)/lib
+BINDIR=$(NABHOME)/bin/$(ARCH)
+LIBDIR=$(NABHOME)/lib/$(ARCH)
INCDIR=$(NABHOME)/include
#
###############################################################################
@@ -37,9 +34,8 @@ INCDIR=$(NABHOME)/include
# included in FLIBS are always searched.)
#
#FLIBS=$(LIBDIR)/cifparse.a $(LIBDIR)/libsym.a
-#FLIBS=../cifparse/cifparse.a
#
-# following for Sun4, Solaris 2.x
+# following for linking in fortran subroutines on Sun4, Solaris 2.x
#
#FLIBS=$(LIBDIR)/cifparse.a $(LIBDIR)/libsym.a -lF77 -lM77 -lsunmath
#
@@ -69,32 +65,40 @@ SHELL= /bin/sh
#
# Set the C compiler, etc.
#
-# (For GNU: cc-->gcc; lex-->flex; yacc-->bison -y -t;
-# Note: If you lexer is "really" flex, you need to set
-# LEX=flex below. For example, on many linux distributions,
-# /usr/bin/lex is really just a pointer to /usr/bin/flex,
-# so LEX=flex is necessary. In general, gcc seems to need
-# flex.)
+# For GNU: cc-->gcc; lex-->flex; yacc-->bison -y -t;
+# Note: If you lexer is "really" flex, you need to set
+# LEX=flex below. For example, on many linux distributions,
+# /usr/bin/lex is really just a pointer to /usr/bin/flex,
+# so LEX=flex is necessary. In general, gcc seems to need
+# flex.
#
+# For 64-bit IRIX, add "-n32" unless 64-bit objects are
+# needed; it is also useful to add "-Wl,-dont_warn_unused"
+# to keep the loader from complaining about libraries that
+# are not used.
+#
+# For RedHat Linux 5.1 (and other linuxes?) add -DHAVE_STRERROR
+#
+# For FreeBSD 4.2-STABLE, there seems to be a dependency
+# on bison. Berkeley yacc was very problematic.
CC= cc
LEX= flex
-YACC= yacc
+YACC= bison -y -t
AR= ar
#
-# Set the C-preprocessor. Code for the preprocessor from gcc is in
-# ../cccp; it gets installed as $(NABHOME)/bin/$(ARCH)/cpp;
+# Set the C-preprocessor. Code for a small preprocessor is in
+# uccp-0.7; it gets installed as $(NABHOME)/bin/$(ARCH)/ucpp;
# this should generally *not* be changed.
#
-#CPP= $(NABHOME)/bin/$(ARCH)/cpp -lang-c++
-#CPP= ../cccp/cpp -lang-c++
-CPP= cc -E -x c++
+# Again, for FreeBSD 4.2-STABLE, I had problems using the system
+# C-preprocessor.
+#
+CPP= ucpp -l
#
# Use these CFLAGS if AVS = 0
-# Notes: for 64-bit IRIX, add "-n32" to both CFLAGS and OCFLAGS
-# for RedHat Linux 5.1 (and other linuxes?) add -DHAVE_STRERROR
#
+CFLAGS=
OCFLAGS= -O
-CFLAGS= -DHAVE_STRERROR ${OCFLAGS}
NABFLAGS=
#
# Use these CFLAGS if AVS = 1
@@ -103,7 +107,7 @@ NABFLAGS=
#OCFLAGS= -O -DAVS=$(AVS) -DAVSDIR='"$(AVSDIR)"' -I$(AVSINCDIR)
#
#
-# For Win95, set SFX to ".exe"; for Unix,NT leave it empty:
+# For Win95/98, set SFX to ".exe"; for Unix,NT leave it empty:
#
#SFX=.exe
SFX=
diff --git a/biology/nab/files/patch-aa b/biology/nab/files/patch-aa
index c8e736e87ab8..a04b27361f18 100644
--- a/biology/nab/files/patch-aa
+++ b/biology/nab/files/patch-aa
@@ -1,25 +1,32 @@
-*** src/Makefile.orig Fri Jan 8 16:06:59 1999
---- src/Makefile Thu Jan 14 16:15:53 1999
+*** Makefile.orig Mon Oct 23 20:01:09 2000
+--- Makefile Sun Jan 28 13:36:22 2001
***************
-*** 7,15 ****
- ./nab -c $(NABFLAGS) $<
- @rm -f $*.c
+*** 1,5 ****
+--- 1,6 ----
+ # top-level Makefile for the NAB suite of programs
-- .c.o: $<
-- $(CC) -c $(CFLAGS) $<
--
- NAB2COBJS= \
- nab2c.o \
- cgen.o \
---- 7,12 ----
++ all: compiler test
+ compiler:
+ -mkdir bin lib include
+ (cd ucpp-0.7; make install )
***************
-*** 77,82 ****
---- 74,81 ----
- yammp.o
+*** 7,15 ****
+ (cd src; make install )
+ (cd nss; make install )
+ (cd tleap; make install )
+! @echo
+! @echo "completed installation of NAB version 4"
+! @echo
- #===========================================================================
-+
-+ all: system
+ # note: "make test" needs to follow "make", since it is very hard to
+ # tell if the compiler is completely "made" or not.
+--- 8,16 ----
+ (cd src; make install )
+ (cd nss; make install )
+ (cd tleap; make install )
+! # @echo
+! # @echo "completed installation of NAB version 4"
+! # @echo
- system: nab \
- nab2c \
+ # note: "make test" needs to follow "make", since it is very hard to
+ # tell if the compiler is completely "made" or not.
diff --git a/biology/nab/files/patch-ac b/biology/nab/files/patch-ac
index 1487c52d9336..e3c6e85535de 100644
--- a/biology/nab/files/patch-ac
+++ b/biology/nab/files/patch-ac
@@ -1,13 +1,18 @@
-*** cccp/Makefile.orig Thu Jan 14 16:20:38 1999
---- cccp/Makefile Thu Jan 14 16:21:08 1999
+*** src/Makefile.orig Mon Nov 13 13:37:07 2000
+--- src/Makefile Mon Jan 29 12:33:37 2001
***************
-*** 4,9 ****
---- 4,11 ----
- ######### no configuration should be needed beyond this line #################
- ##############################################################################
+*** 175,180 ****
+--- 175,187 ----
+ cp defreal.h $(INCDIR)
+ cp nab.h $(INCDIR)
-+ all: cpp$(SFX)
++ beforerealinstall:
++ $(CC) -DBINDIR='"$(PREFIX)/bin"' \
++ -DINCDIR='"$(PREFIX)/include"' \
++ -DLIBDIR='"$(PREFIX)/lib"' \
++ $(CFLAGS) -DCC='"$(CC)"' -DCPP='"$(CPP)"' -DFLIBS='"$(FLIBS)"' \
++ -o ../bin/nab nab.c
+
- cpp$(SFX): cppmain.o cpplib.o cpphash.o cppalloc.o cpperror.o cppexp.o version.o \
- obstack.o alloca.o
- $(CC) $(CFLAGS) -o cpp$(SFX) cppmain.o cpplib.o cpphash.o \
+ uninstall: clean
+ -rm -f \
+ $(BINDIR)/nab2c$(SFX) $(BINDIR)/nab$(SFX) $(INCDIR)/nabcode.h \
diff --git a/biology/nab/files/patch-ad b/biology/nab/files/patch-ad
deleted file mode 100644
index f498e568a3cf..000000000000
--- a/biology/nab/files/patch-ad
+++ /dev/null
@@ -1,13 +0,0 @@
-*** cifparse/Makefile.orig Thu Jan 14 16:21:50 1999
---- cifparse/Makefile Thu Jan 14 16:22:08 1999
-***************
-*** 11,16 ****
---- 11,18 ----
- cifp.tab.o \
- cifparse.o
-
-+ all: cifparse.a
-+
- cifparse.a: $(CIFOBS)
- -rm cifparse.a
- $(AR) rv cifparse.a $(CIFOBS)
diff --git a/biology/nab/files/patch-ae b/biology/nab/files/patch-ae
deleted file mode 100644
index b901073e9ebb..000000000000
--- a/biology/nab/files/patch-ae
+++ /dev/null
@@ -1,19 +0,0 @@
-*** examples/program_7.nab.orig Thu Jan 14 16:53:07 1999
---- examples/program_7.nab Thu Jan 14 16:53:24 1999
-***************
-*** 9,15 ****
- cseq = wc_complement( "acgtacgt", "dna.amber94.rlb", "dna" );
-
- m = wc_helix( seq, "dna.amber94.rlb", "dna", cseq, "dna.amber94.rlb",
-! "dna", 2.25, -4.96, 36.0, 4.38, "" );
-
- b = newbounds(m, "");
- allocate xyz[ 4*m.natoms ];
---- 9,15 ----
- cseq = wc_complement( "acgtacgt", "dna.amber94.rlb", "dna" );
-
- m = wc_helix( seq, "dna.amber94.rlb", "dna", cseq, "dna.amber94.rlb",
-! "dna", 2.25, -4.96, 36.0, 3.38, "" );
-
- b = newbounds(m, "");
- allocate xyz[ 4*m.natoms ];
diff --git a/biology/nab/files/patch-af b/biology/nab/files/patch-af
deleted file mode 100644
index bf908f8b23a6..000000000000
--- a/biology/nab/files/patch-af
+++ /dev/null
@@ -1,23 +0,0 @@
-*** src/reslib.c.orig Tue Apr 21 14:10:50 1998
---- src/reslib.c Mon Feb 1 09:50:35 1999
-***************
-*** 610,618 ****
- fclose( cfp );
- }
-
-! fclose( pfp );
-
-! fclose( bfp );
-
- return( rlp );
- }
---- 610,618 ----
- fclose( cfp );
- }
-
-! if( pfp ) {fclose( pfp );}
-
-! if( bfp ) {fclose( bfp );}
-
- return( rlp );
- }
diff --git a/biology/nab/files/patch-ag b/biology/nab/files/patch-ag
deleted file mode 100644
index d902077dd59d..000000000000
--- a/biology/nab/files/patch-ag
+++ /dev/null
@@ -1,32 +0,0 @@
-*** src/database.c.orig Tue Apr 21 12:17:17 1998
---- src/database.c Tue Mar 9 09:09:06 1999
-***************
-*** 73,78 ****
---- 73,85 ----
-
- #include "database.h"
-
-+ #if (defined(__unix__) || defined(unix)) && !defined(USG)
-+ #include <sys/param.h>
-+ #endif
-+
-+ #if defined(BSD)
-+ #include <math.h>
-+ #endif
-
- #ifndef TRUE
- #define TRUE 1
-***************
-*** 985,991 ****
---- 992,1002 ----
-
- sDBRemoveLeadingSpaces( sLine );
- sDBRemoveFirstString( sLine, sHead );
-+ #if defined(linux) || defined(BSD)
-+ sscanf( sHead, "%lg", dPDbl );
-+ #else
- sscanf( sHead, "%lG", dPDbl );
-+ #endif
-
- }
-
diff --git a/biology/nab/files/patch-ah b/biology/nab/files/patch-ah
deleted file mode 100644
index 71f8da6baac6..000000000000
--- a/biology/nab/files/patch-ah
+++ /dev/null
@@ -1,19 +0,0 @@
-*** semantics/Makefile.orig Fri Mar 10 20:08:16 2000
---- semantics/Makefile Sun Sep 10 18:47:44 2000
-***************
-*** 43,49 ****
- SYM_UPARROW_ASSIGN.rules
-
- checkexpr.c: $(RULES) attribute.tab parse ../src/nab.h ../src/nabgrm.y
-! ./parse *.rules
-
- parse: parse.c
- $(CC) -o parse parse.c
---- 43,49 ----
- SYM_UPARROW_ASSIGN.rules
-
- checkexpr.c: $(RULES) attribute.tab parse ../src/nab.h ../src/nabgrm.y
-! env NABHOME=.. ./parse *.rules
-
- parse: parse.c
- $(CC) -o parse parse.c
diff --git a/biology/nab/files/patch-ai b/biology/nab/files/patch-ai
deleted file mode 100644
index 76cf860b0ce6..000000000000
--- a/biology/nab/files/patch-ai
+++ /dev/null
@@ -1,41 +0,0 @@
-*** tleap/Makefile.orig Tue Jun 20 13:41:55 2000
---- tleap/Makefile Sun Sep 10 19:38:24 2000
-***************
-*** 5,13 ****
- .SUFFIXES:
- .SUFFIXES: .c .o
-
-- .c.o: $<
-- $(CC) -c $(CFLAGS) -DSYSV $<
--
- #
- # Absolutely necessary routines
- #
---- 5,10 ----
-***************
-*** 76,81 ****
---- 73,79 ----
- OUL2P= utilLib2Pdb.o
-
- TLEAP_OBJ= $(OA) $(OG) $(OO) $(OL) $(OC)
-+ all: teLeap$(SFX)
- teLeap$(SFX): $(TLEAP_OBJ)
- $(CC) -o $@ $(TLEAP_OBJ) -lm
-
-***************
-*** 409,415 ****
- zMatrix.o: zMatrix.h
-
- install: teLeap$(SFX)
-! mv teLeap$(SFX) $(BINDIR)
-
- uninstall: clean
- -rm $(BINDIR)/teLeap$(SFX)
---- 407,413 ----
- zMatrix.o: zMatrix.h
-
- install: teLeap$(SFX)
-! mv teLeap$(SFX) $(PREFIX)/bin
-
- uninstall: clean
- -rm $(BINDIR)/teLeap$(SFX)